]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
Merge branch 'debugger'
[empathy.git] / src / Makefile.am
index 5294eac0916ed7683620bfdaa2087294555d54d8..42485b7d1fed7105ee9f131effd608787523db09 100644 (file)
@@ -1,7 +1,14 @@
+include $(top_srcdir)/tools/shave.mk
+include $(top_srcdir)/tools/flymake.mk
+
 AM_CPPFLAGS =                                          \
        -I$(top_srcdir)                                 \
+       -DG_LOG_DOMAIN=\"empathy\"                      \
        $(EMPATHY_CFLAGS)                               \
        $(LIBNOTIFY_CFLAGS)                             \
+       $(LIBCHAMPLAIN_CFLAGS)                          \
+       $(DISABLE_DEPRECATED)                           \
+       $(WEBKIT_CFLAGS)                                \
        $(WARN_CFLAGS)
 
 LDADD =                                                                \
@@ -9,7 +16,9 @@ LDADD =                                                                \
        $(top_builddir)/libempathy/libempathy.la                \
        $(top_builddir)/extensions/libemp-extensions.la         \
        $(LIBNOTIFY_LIBS)                                       \
-       $(EMPATHY_LIBS)
+       $(EMPATHY_LIBS)                                         \
+       $(LIBCHAMPLAIN_LIBS)                                    \
+       $(WEBKIT_LIBS)
 
 bin_PROGRAMS =                 \
        empathy                 \
@@ -19,48 +28,80 @@ BUILT_SOURCES= \
        empathy-tube-dispatch-enumtypes.h \
        empathy-tube-dispatch-enumtypes.c
 
-empathy_SOURCES =                                                      \
-       bacon-message-connection.c bacon-message-connection.h           \
+empathy_handwritten_source = \
        empathy.c                                                       \
        empathy-about-dialog.c empathy-about-dialog.h                   \
        empathy-accounts-dialog.c empathy-accounts-dialog.h             \
        empathy-call-window.c empathy-call-window.h                     \
+       empathy-call-window-fullscreen.c empathy-call-window-fullscreen.h                       \
        empathy-chatrooms-window.c empathy-chatrooms-window.h           \
+       empathy-debug-dialog.c empathy-debug-dialog.h                   \
        empathy-chat-window.c empathy-chat-window.h                     \
        empathy-event-manager.c empathy-event-manager.h                 \
        empathy-ft-manager.c empathy-ft-manager.h                       \
        empathy-import-dialog.c empathy-import-dialog.h                 \
        empathy-import-pidgin.c empathy-import-pidgin.h                 \
        empathy-main-window.c empathy-main-window.h                     \
+       empathy-misc.c empathy-misc.h                                   \
        empathy-new-chatroom-dialog.c empathy-new-chatroom-dialog.h     \
        empathy-preferences.c empathy-preferences.h                     \
+       empathy-sidebar.c empathy-sidebar.h                     \
        empathy-status-icon.c empathy-status-icon.h                     \
-       empathy-tube-dispatch.c empathy-tube-dispatch.h                 \
+       empathy-tube-dispatch.c empathy-tube-dispatch.h
+
+empathy_SOURCES =                                                      \
+       $(empathy_handwritten_source)                                   \
+       bacon-message-connection.c bacon-message-connection.h           \
        ephy-spinner.c ephy-spinner.h
 
 nodist_empathy_SOURCES = $(BUILT_SOURCES)
 
 empathy_logs_SOURCES = empathy-logs.c
 
-gladedir = $(datadir)/empathy
-glade_DATA =                                   \
-       empathy-accounts-dialog.glade           \
-       empathy-call-window.glade               \
-       empathy-chatrooms-window.glade          \
-       empathy-chat-window.glade               \
-       empathy-ft-manager.glade                \
-       empathy-import-dialog.glade             \
-       empathy-main-window.glade               \
-       empathy-new-chatroom-dialog.glade       \
-       empathy-preferences.glade               \
-       empathy-status-icon.glade
+check_c_sources = \
+    $(empathy_handwritten_source) \
+    $(empathy_logs_SOURCES)
+include $(top_srcdir)/tools/check-coding-style.mk
+check-local: check-coding-style
+
+uidir = $(datadir)/empathy
+ui_DATA =                                      \
+       empathy-accounts-dialog.ui              \
+       empathy-call-window.ui                  \
+       empathy-call-window-fullscreen.ui                       \
+       empathy-chatrooms-window.ui             \
+       empathy-chat-window.ui                  \
+       empathy-ft-manager.ui                   \
+       empathy-import-dialog.ui                \
+       empathy-main-window.ui                  \
+       empathy-new-chatroom-dialog.ui          \
+       empathy-preferences.ui                  \
+       empathy-status-icon.ui
+
+EXTRA_DIST =                   \
+       $(autostart_DATA)       \
+       $(ui_DATA)
+
+if HAVE_LIBCHAMPLAIN
+empathy_handwritten_source +=                          \
+       empathy-map-view.c                      \
+       empathy-map-view.h
+
+ui_DATA +=                                     \
+       empathy-map-view.ui
+else
+EXTRA_DIST +=                                  \
+       empathy-map-view.c                      \
+       empathy-map-view.h                      \
+       empathy-map-view.ui
+endif
 
 dist_man_MANS =                        \
        empathy.1
 
 # rules for making the glib enum objects
 %-enumtypes.h: %.h Makefile.in
-       glib-mkenums \
+       $(QUIET_GEN)glib-mkenums \
        --fhead "#ifndef __$(shell echo $* | tr [:lower:]- [:upper:]_)_ENUM_TYPES_H__\n#define __$(shell echo $* | tr [:lower:]- [:upper:]_)_ENUM_TYPES_H__\n\n#include <glib-object.h>\n\nG_BEGIN_DECLS\n" \
        --fprod "/* enumerations from \"@filename@\" */\n" \
        --vhead "GType @enum_name@_get_type (void);\n#define $(shell echo $* | tr [:lower:]- [:upper:]_ | sed 's/_.*//')_TYPE_@ENUMSHORT@ (@enum_name@_get_type())\n"         \
@@ -68,7 +109,7 @@ dist_man_MANS =                      \
        $< > $@
 
 %-enumtypes.c: %.h Makefile.in
-       glib-mkenums \
+       $(QUIET_GEN)glib-mkenums \
        --fhead "#include <$*.h>\n#include <$*-enumtypes.h>" \
        --fprod "\n/* enumerations from \"@filename@\" */" \
        --vhead "GType\n@enum_name@_get_type (void)\n{\n  static GType etype = 0;\n  if (etype == 0) {\n    static const G@Type@Value values[] = {"     \
@@ -76,9 +117,5 @@ dist_man_MANS =                      \
        --vtail "      { 0, NULL, NULL }\n    };\n    etype = g_@type@_register_static (\"@EnumName@\", values);\n  }\n  return etype;\n}\n" \
        $< > $@
 
-EXTRA_DIST =                   \
-       $(autostart_DATA)       \
-       $(glade_DATA)
-
 CLEANFILES = $(BUILT_SOURCES)