]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
Merge branch 'debug'
[empathy.git] / src / Makefile.am
index b776396aaa13a78ca8ac5fbb702630f9770f9efe..081b6f4f2aced30d142f0f9b58cc9ccb9416c3f8 100644 (file)
@@ -1,16 +1,20 @@
+include $(top_srcdir)/tools/shave.mk
+
 AM_CPPFLAGS =                                          \
        -I$(top_srcdir)                                 \
        $(EMPATHY_CFLAGS)                               \
        $(LIBNOTIFY_CFLAGS)                             \
-       $(WARN_CFLAGS)                                  \
+       $(LIBCHAMPLAIN_CFLAGS)                          \
        $(DISABLE_DEPRECATED)
+       $(WARN_CFLAGS)
 
 LDADD =                                                                \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
        $(top_builddir)/libempathy/libempathy.la                \
        $(top_builddir)/extensions/libemp-extensions.la         \
        $(LIBNOTIFY_LIBS)                                       \
-       $(EMPATHY_LIBS)
+       $(EMPATHY_LIBS)                                         \
+       $(LIBCHAMPLAIN_LIBS)
 
 bin_PROGRAMS =                 \
        empathy                 \
@@ -20,12 +24,12 @@ BUILT_SOURCES= \
        empathy-tube-dispatch-enumtypes.h \
        empathy-tube-dispatch-enumtypes.c
 
-empathy_SOURCES =                                                      \
-       bacon-message-connection.c bacon-message-connection.h           \
+empathy_handwritten_source = \
        empathy.c                                                       \
        empathy-about-dialog.c empathy-about-dialog.h                   \
        empathy-accounts-dialog.c empathy-accounts-dialog.h             \
        empathy-call-window.c empathy-call-window.h                     \
+       empathy-call-window-fullscreen.c empathy-call-window-fullscreen.h                       \
        empathy-chatrooms-window.c empathy-chatrooms-window.h           \
        empathy-debug-dialog.c empathy-debug-dialog.h                   \
        empathy-chat-window.c empathy-chat-window.h                     \
@@ -39,17 +43,28 @@ empathy_SOURCES =                                                   \
        empathy-preferences.c empathy-preferences.h                     \
        empathy-sidebar.c empathy-sidebar.h                     \
        empathy-status-icon.c empathy-status-icon.h                     \
-       empathy-tube-dispatch.c empathy-tube-dispatch.h                 \
+       empathy-tube-dispatch.c empathy-tube-dispatch.h
+
+empathy_SOURCES =                                                      \
+       $(empathy_handwritten_source)                                   \
+       bacon-message-connection.c bacon-message-connection.h           \
        ephy-spinner.c ephy-spinner.h
 
 nodist_empathy_SOURCES = $(BUILT_SOURCES)
 
 empathy_logs_SOURCES = empathy-logs.c
 
+check_c_sources = \
+    $(empathy_handwritten_source) \
+    $(empathy_logs_SOURCES)
+include $(top_srcdir)/tools/check-coding-style.mk
+check-local: check-coding-style
+
 uidir = $(datadir)/empathy
 ui_DATA =                                      \
        empathy-accounts-dialog.ui              \
        empathy-call-window.ui                  \
+       empathy-call-window-fullscreen.ui                       \
        empathy-chatrooms-window.ui             \
        empathy-chat-window.ui                  \
        empathy-ft-manager.ui                   \
@@ -59,12 +74,20 @@ ui_DATA =                                   \
        empathy-preferences.ui                  \
        empathy-status-icon.ui
 
+if HAVE_LIBCHAMPLAIN
+empathy_SOURCES +=                             \
+       empathy-map-view.c empathy-map-view.h
+
+ui_DATA +=                                     \
+       empathy-map-view.ui
+endif
+
 dist_man_MANS =                        \
        empathy.1
 
 # rules for making the glib enum objects
 %-enumtypes.h: %.h Makefile.in
-       glib-mkenums \
+       $(QUIET_GEN)glib-mkenums \
        --fhead "#ifndef __$(shell echo $* | tr [:lower:]- [:upper:]_)_ENUM_TYPES_H__\n#define __$(shell echo $* | tr [:lower:]- [:upper:]_)_ENUM_TYPES_H__\n\n#include <glib-object.h>\n\nG_BEGIN_DECLS\n" \
        --fprod "/* enumerations from \"@filename@\" */\n" \
        --vhead "GType @enum_name@_get_type (void);\n#define $(shell echo $* | tr [:lower:]- [:upper:]_ | sed 's/_.*//')_TYPE_@ENUMSHORT@ (@enum_name@_get_type())\n"         \
@@ -72,7 +95,7 @@ dist_man_MANS =                       \
        $< > $@
 
 %-enumtypes.c: %.h Makefile.in
-       glib-mkenums \
+       $(QUIET_GEN)glib-mkenums \
        --fhead "#include <$*.h>\n#include <$*-enumtypes.h>" \
        --fprod "\n/* enumerations from \"@filename@\" */" \
        --vhead "GType\n@enum_name@_get_type (void)\n{\n  static GType etype = 0;\n  if (etype == 0) {\n    static const G@Type@Value values[] = {"     \