]> git.0d.be Git - empathy.git/blobdiff - python/pyempathy/Makefile.am
Empathy should not require python-config. Fixes bug #525562 (Frederic Peters).
[empathy.git] / python / pyempathy / Makefile.am
index 4778fdf20340c5a6a96c10f5b1ed984e6196f5dc..a2b76b26432231de7199a148758442353abeab2e 100644 (file)
@@ -6,13 +6,13 @@ AM_CPPFLAGS =                                           \
        -I$(top_srcdir)                                 \
        -DDATADIR=\""$(datadir)"\"                      \
        $(PYTHON_BINDING_CFLAGS)                        \
-       `python-config --cflags`                        \
+       $(PYTHON_INCLUDES)                              \
        $(WARN_CFLAGS)
 
 BUILT_SOURCES =                                        \
        pyempathy.c                                     
 
-pyempathydir = $(prefix)/lib/`pyversions -d`/site-packages
+pyempathydir = $(pyexecdir)
 pyempathy_LTLIBRARIES = empathy.la
 
 empathy_la_SOURCES =                                   \
@@ -24,7 +24,6 @@ empathy_la_LIBADD =                                   \
        $(top_builddir)/libempathy/libempathy.la
 
 empathy_la_LDFLAGS =                                   \
-       `python-config --libs`                          \
        -module -avoid-version
 
 pyempathy.c: pyempathy.override pyempathy.defs