]> git.0d.be Git - empathy.git/blobdiff - python/pyempathy/Makefile.am
Empathy should not require python-config. Fixes bug #525562 (Frederic Peters).
[empathy.git] / python / pyempathy / Makefile.am
index 3c0bdbf2d317df6ae25e1555141c897cb4e8e190..a2b76b26432231de7199a148758442353abeab2e 100644 (file)
@@ -6,13 +6,13 @@ AM_CPPFLAGS =                                           \
        -I$(top_srcdir)                                 \
        -DDATADIR=\""$(datadir)"\"                      \
        $(PYTHON_BINDING_CFLAGS)                        \
-       `python-config --cflags`                        \
+       $(PYTHON_INCLUDES)                              \
        $(WARN_CFLAGS)
 
 BUILT_SOURCES =                                        \
        pyempathy.c                                     
 
-pyempathydir = $(prefix)/lib/`pyversions -d`/site-packages
+pyempathydir = $(pyexecdir)
 pyempathy_LTLIBRARIES = empathy.la
 
 empathy_la_SOURCES =                                   \
@@ -24,15 +24,19 @@ empathy_la_LIBADD =                                 \
        $(top_builddir)/libempathy/libempathy.la
 
 empathy_la_LDFLAGS =                                   \
-       `python-config --libs`                          \
        -module -avoid-version
 
 pyempathy.c: pyempathy.override pyempathy.defs
-       pygtk-codegen-2.0 --prefix empathy              \
+       pygtk-codegen-2.0                               \
+               --prefix empathy                        \
                --register $(PYDEFS)/gdk-types.defs     \
                --register $(PYDEFS)/gtk-types.defs     \
                --override pyempathy.override           \
                pyempathy.defs > $@ 
 
+EXTRA_DIST =                   \
+       pyempathy.override      \
+       pyempathy.defs
+
 CLEANFILES = $(BUILT_SOURCES)