]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
Merge remote-tracking branch 'jonny/ft'
[empathy.git] / libempathy / Makefile.am
index 746803e059bfcc2eb55be7792c5aa7598672788c..cd03022738025a7aa923ca0b4062dafc11803a28 100644 (file)
@@ -8,127 +8,166 @@ AM_CPPFLAGS =                                           \
        -DDATADIR=\""$(datadir)"\"                      \
        -DLOCALEDIR=\""$(datadir)/locale"\"             \
        -DG_LOG_DOMAIN=\"empathy\"                      \
+       -DGCR_API_SUBJECT_TO_CHANGE                     \
        $(EMPATHY_CFLAGS)                               \
+       $(YELL_CFLAGS)                                  \
        $(GEOCLUE_CFLAGS)                               \
+       $(GEOCODE_CFLAGS)                               \
        $(NETWORK_MANAGER_CFLAGS)                       \
        $(CONNMAN_CFLAGS)                               \
+       $(UDEV_CFLAGS)                                  \
+       $(GOA_CFLAGS)                                   \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
 BUILT_SOURCES =                                        \
-       empathy-marshal.h                               \
-       empathy-marshal.c                               \
-       empathy-marshal.list                            \
        empathy-enum-types.h                            \
        empathy-enum-types.c
 
 noinst_LTLIBRARIES = libempathy.la
 
 libempathy_headers =                           \
+       action-chain-internal.h                 \
        empathy-account-settings.h              \
-       empathy-call-factory.h                  \
-       empathy-call-handler.h                  \
+       empathy-auth-factory.h                  \
+       empathy-camera-monitor.h                \
        empathy-chatroom-manager.h              \
        empathy-chatroom.h                      \
+       empathy-client-factory.h \
        empathy-connection-managers.h           \
        empathy-connectivity.h                  \
+       empathy-connection-aggregator.h         \
        empathy-contact-groups.h                \
        empathy-contact-list.h                  \
        empathy-contact-manager.h               \
        empathy-contact.h                       \
        empathy-debug.h                         \
-       empathy-dispatch-operation.h            \
-       empathy-dispatcher.h                    \
        empathy-ft-factory.h                    \
        empathy-ft-handler.h                    \
        empathy-gsettings.h                     \
-       empathy-handler.h                       \
-       empathy-idle.h                          \
+       empathy-presence-manager.h                              \
+       empathy-individual-manager.h            \
        empathy-irc-network-manager.h           \
        empathy-irc-network.h                   \
        empathy-irc-server.h                    \
+       empathy-keyring.h                       \
        empathy-location.h                      \
        empathy-message.h                       \
+       empathy-request-util.h                  \
+       empathy-server-sasl-handler.h           \
+       empathy-server-tls-handler.h            \
        empathy-status-presets.h                \
        empathy-time.h                          \
-       empathy-tp-call.h                       \
+       empathy-tls-certificate.h               \
+       empathy-tls-verifier.h                  \
        empathy-tp-chat.h                       \
        empathy-tp-contact-factory.h            \
        empathy-tp-contact-list.h               \
-       empathy-tp-file.h                       \
        empathy-tp-roomlist.h                   \
+       empathy-tp-streamed-media.h             \
        empathy-types.h                         \
        empathy-utils.h
 
-libempathy_la_SOURCES =                                        \
+libempathy_handwritten_source =                                \
        $(libempathy_headers)                           \
+       action-chain.c                                  \
        empathy-account-settings.c                      \
-       empathy-call-factory.c                          \
-       empathy-call-handler.c                          \
+       empathy-auth-factory.c                          \
+       empathy-camera-monitor.c                        \
        empathy-chatroom-manager.c                      \
        empathy-chatroom.c                              \
+       empathy-client-factory.c \
        empathy-connection-managers.c                   \
        empathy-connectivity.c                          \
+       empathy-connection-aggregator.c         \
        empathy-contact-groups.c                        \
        empathy-contact-list.c                          \
        empathy-contact-manager.c                       \
        empathy-contact.c                               \
        empathy-debug.c                                 \
-       empathy-dispatch-operation.c                    \
-       empathy-dispatcher.c                            \
        empathy-ft-factory.c                            \
        empathy-ft-handler.c                            \
-       empathy-handler.c                               \
-       empathy-idle.c                                  \
+       empathy-presence-manager.c                                      \
+       empathy-individual-manager.c                    \
        empathy-irc-network-manager.c                   \
        empathy-irc-network.c                           \
        empathy-irc-server.c                            \
+       empathy-keyring.c                               \
        empathy-message.c                               \
+       empathy-request-util.c                          \
+       empathy-server-sasl-handler.c                   \
+       empathy-server-tls-handler.c                    \
        empathy-status-presets.c                        \
        empathy-time.c                                  \
-       empathy-tp-call.c                               \
+       empathy-tls-certificate.c                       \
+       empathy-tls-verifier.c                          \
        empathy-tp-chat.c                               \
        empathy-tp-contact-factory.c                    \
        empathy-tp-contact-list.c                       \
-       empathy-tp-file.c                               \
        empathy-tp-roomlist.c                           \
+       empathy-tp-streamed-media.c                     \
        empathy-utils.c
 
+# these are sources that depend on GOA
+goa_sources = \
+       empathy-goa-auth-handler.c \
+       empathy-goa-auth-handler.h \
+       $(NULL)
+
+libempathy_la_SOURCES = \
+       $(libempathy_handwritten_source) \
+       cheese-camera-device-monitor.c cheese-camera-device-monitor.h
+
+dtddir = $(datadir)/empathy
+dtd_DATA =                                     \
+       empathy-status-presets.dtd              \
+       empathy-contact-groups.dtd              \
+       empathy-chatroom-manager.dtd            \
+       empathy-irc-networks.dtd
+
+ircnetworksdir = $(datadir)/empathy
+ircnetworks_DATA =             \
+       irc-networks.xml
+
+EXTRA_DIST =                   \
+       $(dtd_DATA)             \
+       $(ircnetworks_DATA)
+
+CLEANFILES =                           \
+       $(BUILT_SOURCES)                \
+       stamp-empathy-enum-types.h
+
+if HAVE_GOA
+libempathy_la_SOURCES += $(goa_sources)
+else
+EXTRA_DIST += $(goa_sources)
+endif
+
 # do not distribute generated files
 nodist_libempathy_la_SOURCES =\
        $(BUILT_SOURCES)
 
 libempathy_la_LIBADD =         \
        $(top_builddir)/extensions/libemp-extensions.la \
+       $(top_builddir)/telepathy-yell/telepathy-yell/libtelepathy-yell.la \
+       $(GCR_LIBS) \
        $(EMPATHY_LIBS) \
        $(GEOCLUE_LIBS) \
+       $(GEOCODE_LIBS) \
        $(NETWORK_MANAGER_LIBS) \
-       $(CONNMAN_LIBS)
+       $(CONNMAN_LIBS) \
+       $(UDEV_LIBS) \
+       $(GOA_LIBS) \
+       $(LIBM)
 
 check_c_sources = \
-    $(libempathy_la_SOURCES) \
-    $(libempathy_headers)
+    $(libempathy_handwritten_source) \
+    $(goa_sources) \
+    $(NULL)
+
 include $(top_srcdir)/tools/check-coding-style.mk
 check-local: check-coding-style
 
-empathy-marshal.list: $(libempathy_la_SOURCES) Makefile.am
-       $(AM_V_GEN)( cd $(srcdir) && \
-       sed -n -e 's/.*empathy_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
-       $(libempathy_la_SOURCES) ) \
-       | sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
-       @if cmp -s $@.tmp $@; then \
-               rm $@.tmp; \
-       else \
-               mv $@.tmp $@; \
-       fi
-
-%-marshal.h: %-marshal.list Makefile
-       $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
-
-%-marshal.c: %-marshal.list Makefile
-       $(AM_V_GEN)echo "#include \"empathy-marshal.h\"" > $@ && \
-       $(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
-
 empathy-enum-types.h: stamp-empathy-enum-types.h
        $(AM_V_GEN)true
 stamp-empathy-enum-types.h: $(libempathy_headers) Makefile
@@ -166,23 +205,3 @@ empathy-enum-types.c: $(libempathy_headers) Makefile
                $(libempathy_headers) ) > xgen-gtc \
        && cp xgen-gtc $(@F) \
        && rm -f xgen-gtc
-
-dtddir = $(datadir)/empathy
-dtd_DATA =                                     \
-       empathy-status-presets.dtd              \
-       empathy-contact-groups.dtd              \
-       empathy-chatroom-manager.dtd            \
-       empathy-irc-networks.dtd
-
-ircnetworksdir = $(datadir)/empathy
-ircnetworks_DATA =             \
-       irc-networks.xml
-
-EXTRA_DIST =                   \
-       empathy-marshal.list    \
-       $(dtd_DATA)             \
-       $(ircnetworks_DATA)
-
-CLEANFILES =                           \
-       $(BUILT_SOURCES)                \
-       stamp-empathy-enum-types.h