]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
Merge remote-tracking branch 'jonny/ft'
[empathy.git] / libempathy / Makefile.am
index 079b4736ba25d4edd7a78b54edbcb0ca952559f8..cd03022738025a7aa923ca0b4062dafc11803a28 100644 (file)
@@ -16,6 +16,7 @@ AM_CPPFLAGS =                                           \
        $(NETWORK_MANAGER_CFLAGS)                       \
        $(CONNMAN_CFLAGS)                               \
        $(UDEV_CFLAGS)                                  \
+       $(GOA_CFLAGS)                                   \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
@@ -35,6 +36,7 @@ libempathy_headers =                          \
        empathy-client-factory.h \
        empathy-connection-managers.h           \
        empathy-connectivity.h                  \
+       empathy-connection-aggregator.h         \
        empathy-contact-groups.h                \
        empathy-contact-list.h                  \
        empathy-contact-manager.h               \
@@ -61,7 +63,6 @@ libempathy_headers =                          \
        empathy-tp-chat.h                       \
        empathy-tp-contact-factory.h            \
        empathy-tp-contact-list.h               \
-       empathy-tp-file.h                       \
        empathy-tp-roomlist.h                   \
        empathy-tp-streamed-media.h             \
        empathy-types.h                         \
@@ -78,6 +79,7 @@ libempathy_handwritten_source =                               \
        empathy-client-factory.c \
        empathy-connection-managers.c                   \
        empathy-connectivity.c                          \
+       empathy-connection-aggregator.c         \
        empathy-contact-groups.c                        \
        empathy-contact-list.c                          \
        empathy-contact-manager.c                       \
@@ -102,15 +104,45 @@ libempathy_handwritten_source =                           \
        empathy-tp-chat.c                               \
        empathy-tp-contact-factory.c                    \
        empathy-tp-contact-list.c                       \
-       empathy-tp-file.c                               \
        empathy-tp-roomlist.c                           \
        empathy-tp-streamed-media.c                     \
        empathy-utils.c
 
+# these are sources that depend on GOA
+goa_sources = \
+       empathy-goa-auth-handler.c \
+       empathy-goa-auth-handler.h \
+       $(NULL)
+
 libempathy_la_SOURCES = \
        $(libempathy_handwritten_source) \
        cheese-camera-device-monitor.c cheese-camera-device-monitor.h
 
+dtddir = $(datadir)/empathy
+dtd_DATA =                                     \
+       empathy-status-presets.dtd              \
+       empathy-contact-groups.dtd              \
+       empathy-chatroom-manager.dtd            \
+       empathy-irc-networks.dtd
+
+ircnetworksdir = $(datadir)/empathy
+ircnetworks_DATA =             \
+       irc-networks.xml
+
+EXTRA_DIST =                   \
+       $(dtd_DATA)             \
+       $(ircnetworks_DATA)
+
+CLEANFILES =                           \
+       $(BUILT_SOURCES)                \
+       stamp-empathy-enum-types.h
+
+if HAVE_GOA
+libempathy_la_SOURCES += $(goa_sources)
+else
+EXTRA_DIST += $(goa_sources)
+endif
+
 # do not distribute generated files
 nodist_libempathy_la_SOURCES =\
        $(BUILT_SOURCES)
@@ -125,10 +157,14 @@ libempathy_la_LIBADD =            \
        $(NETWORK_MANAGER_LIBS) \
        $(CONNMAN_LIBS) \
        $(UDEV_LIBS) \
+       $(GOA_LIBS) \
        $(LIBM)
 
 check_c_sources = \
-    $(libempathy_handwritten_source)
+    $(libempathy_handwritten_source) \
+    $(goa_sources) \
+    $(NULL)
+
 include $(top_srcdir)/tools/check-coding-style.mk
 check-local: check-coding-style
 
@@ -169,22 +205,3 @@ empathy-enum-types.c: $(libempathy_headers) Makefile
                $(libempathy_headers) ) > xgen-gtc \
        && cp xgen-gtc $(@F) \
        && rm -f xgen-gtc
-
-dtddir = $(datadir)/empathy
-dtd_DATA =                                     \
-       empathy-status-presets.dtd              \
-       empathy-contact-groups.dtd              \
-       empathy-chatroom-manager.dtd            \
-       empathy-irc-networks.dtd
-
-ircnetworksdir = $(datadir)/empathy
-ircnetworks_DATA =             \
-       irc-networks.xml
-
-EXTRA_DIST =                   \
-       $(dtd_DATA)             \
-       $(ircnetworks_DATA)
-
-CLEANFILES =                           \
-       $(BUILT_SOURCES)                \
-       stamp-empathy-enum-types.h