]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
Import tools from telepathy-glib 0.7.3 and build a static libemp-extensions.la.
[empathy.git] / libempathy / Makefile.am
index 5d0c021b26cd53cc8f073fc395f6f5e259f37fd1..adf9b7d5b276ddc8197144378bb3192c28d7bca7 100644 (file)
@@ -1,6 +1,7 @@
 AM_CPPFLAGS =                                           \
        -I.                                             \
        -I$(top_srcdir)                                 \
+       -I$(top_builddir)                               \
        -DDATADIR=\""$(datadir)"\"                      \
        $(LIBEMPATHY_CFLAGS)                            \
        $(WARN_CFLAGS)
@@ -41,13 +42,17 @@ libempathy_la_SOURCES =                                     \
        empathy-chandler.c                              \
        empathy-filter.c                                \
        empathy-idle.c                                  \
-       empathy-log-manager.c
+       empathy-log-manager.c                           \
+       empathy-irc-network-manager.c                   \
+       empathy-irc-network.c                           \
+       empathy-irc-server.c
 
 # do not distribute generated files
 nodist_libempathy_la_SOURCES =\
        $(BUILT_SOURCES)
 
 libempathy_la_LIBADD =         \
+       $(top_builddir)/extensions/libemp-extensions.la \
        $(LIBEMPATHY_LIBS)
 
 libempathy_la_LDFLAGS =                \
@@ -78,7 +83,10 @@ libempathy_headers =                         \
        empathy-chandler.h                      \
        empathy-filter.h                        \
        empathy-idle.h                          \
-       empathy-log-manager.h
+       empathy-log-manager.h                   \
+       empathy-irc-network-manager.h           \
+       empathy-irc-network.h                   \
+       empathy-irc-server.h
 
 libempathy_includedir = $(includedir)/libempathy/
 libempathy_include_HEADERS =                   \
@@ -87,7 +95,7 @@ libempathy_include_HEADERS =                  \
 
 empathy-marshal.list: $(libempathy_la_SOURCES) Makefile.am
        ( cd $(srcdir) && \
-       sed -n -e 's/.*empathy_marshal_\([[:upper:]]*__[[:upper:]_]*\).*/\1/p' \
+       sed -n -e 's/.*empathy_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
        $(libempathy_la_SOURCES) ) \
        | sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
        if cmp -s $@.tmp $@; then \
@@ -154,12 +162,17 @@ dtddir = $(datadir)/empathy
 dtd_DATA =                                     \
        empathy-status-presets.dtd              \
        empathy-contact-groups.dtd              \
-       empathy-chatroom-manager.dtd
+       empathy-chatroom-manager.dtd            \
+       empathy-irc-networks.dtd
 
 stylesheetdir = $(datadir)/empathy
 stylesheet_DATA =              \
        empathy-log-manager.xsl
 
+ircnetworksdir = $(datadir)/empathy
+ircnetworks_DATA =             \
+       irc-networks.xml
+
 pkgconfigdir = $(libdir)/pkgconfig
 pkgconfig_DATA = libempathy.pc
 
@@ -169,7 +182,8 @@ EXTRA_DIST =                        \
        empathy-filter.xml      \
        tp-stream-engine.xml    \
        $(stylesheet_DATA)      \
-       $(dtd_DATA)
+       $(dtd_DATA)             \
+       $(ircnetworks_DATA)
 
 CLEANFILES =                           \
        $(BUILT_SOURCES)                \