]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
Import tools from telepathy-glib 0.7.3 and build a static libemp-extensions.la.
[empathy.git] / libempathy / Makefile.am
index 0480d0bff1263da5596ddcee8fa5c3834143ac6f..adf9b7d5b276ddc8197144378bb3192c28d7bca7 100644 (file)
@@ -1,6 +1,7 @@
 AM_CPPFLAGS =                                           \
        -I.                                             \
        -I$(top_srcdir)                                 \
+       -I$(top_builddir)                               \
        -DDATADIR=\""$(datadir)"\"                      \
        $(LIBEMPATHY_CFLAGS)                            \
        $(WARN_CFLAGS)
@@ -8,27 +9,30 @@ AM_CPPFLAGS =                                           \
 BUILT_SOURCES =                                        \
        empathy-marshal.h                               \
        empathy-marshal.c                               \
+       empathy-marshal.list                            \
        empathy-enum-types.h                            \
        empathy-enum-types.c                            \
        empathy-filter-glue.h                           \
-       empathy-chandler-glue.h
+       empathy-chandler-glue.h                         \
+       tp-stream-engine-gen.h
 
 lib_LTLIBRARIES = libempathy.la
 
 libempathy_la_SOURCES =                                        \
-       empathy-conf.c                                  \
        empathy-avatar.c                                \
        empathy-time.c                                  \
-       empathy-presence.c                              \
+       empathy-status-presets.c                        \
        empathy-debug.c                                 \
        empathy-utils.c                                 \
        empathy-message.c                               \
        empathy-chatroom-manager.c                      \
        empathy-chatroom.c                              \
        empathy-contact.c                               \
+       empathy-contact-groups.c                        \
        empathy-contact-list.c                          \
        empathy-contact-manager.c                       \
        empathy-contact-factory.c                       \
+       empathy-tp-contact-factory.c                    \
        empathy-tp-group.c                              \
        empathy-tp-contact-list.c                       \
        empathy-tp-chat.c                               \
@@ -38,32 +42,38 @@ libempathy_la_SOURCES =                                     \
        empathy-chandler.c                              \
        empathy-filter.c                                \
        empathy-idle.c                                  \
-       empathy-log-manager.c
+       empathy-log-manager.c                           \
+       empathy-irc-network-manager.c                   \
+       empathy-irc-network.c                           \
+       empathy-irc-server.c
 
 # do not distribute generated files
 nodist_libempathy_la_SOURCES =\
        $(BUILT_SOURCES)
 
 libempathy_la_LIBADD =         \
+       $(top_builddir)/extensions/libemp-extensions.la \
        $(LIBEMPATHY_LIBS)
 
 libempathy_la_LDFLAGS =                \
-       -version-info ${LIBEMPATHY_CURRENT}:${LIBEMPATHY_REVISION}:${LIBEMPATHY_AGE}
+       -version-info ${LIBEMPATHY_CURRENT}:${LIBEMPATHY_REVISION}:${LIBEMPATHY_AGE} \
+       -export-symbols-regex ^empathy_
 
 libempathy_headers =                           \
-       empathy-conf.h                          \
        empathy-avatar.h                        \
        empathy-time.h                          \
-       empathy-presence.h                      \
+       empathy-status-presets.h                \
        empathy-debug.h                         \
        empathy-utils.h                         \
        empathy-message.h                       \
        empathy-chatroom-manager.h              \
        empathy-chatroom.h                      \
        empathy-contact.h                       \
+       empathy-contact-groups.h                \
        empathy-contact-list.h                  \
        empathy-contact-manager.h               \
        empathy-contact-factory.h               \
+       empathy-tp-contact-factory.h            \
        empathy-tp-group.h                      \
        empathy-tp-contact-list.h               \
        empathy-tp-chat.h                       \
@@ -74,19 +84,32 @@ libempathy_headers =                                \
        empathy-filter.h                        \
        empathy-idle.h                          \
        empathy-log-manager.h                   \
-       tp-stream-engine-gen.h
+       empathy-irc-network-manager.h           \
+       empathy-irc-network.h                   \
+       empathy-irc-server.h
 
 libempathy_includedir = $(includedir)/libempathy/
 libempathy_include_HEADERS =                   \
        $(libempathy_headers)                   \
        empathy-enum-types.h
 
+empathy-marshal.list: $(libempathy_la_SOURCES) Makefile.am
+       ( cd $(srcdir) && \
+       sed -n -e 's/.*empathy_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
+       $(libempathy_la_SOURCES) ) \
+       | sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
+       if cmp -s $@.tmp $@; then \
+               rm $@.tmp; \
+       else \
+               mv $@.tmp $@; \
+       fi
+
 %-marshal.h: %-marshal.list Makefile
-       $(GLIB_GENMARSHAL) --header --prefix=$(subst -,_,$*)_marshal $< > $*-marshal.h
+       $(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
 
 %-marshal.c: %-marshal.list Makefile
        echo "#include \"empathy-marshal.h\"" > $@ && \
-       $(GLIB_GENMARSHAL) --body --prefix=$(subst -,_,$*)_marshal $< >> $*-marshal.c
+       $(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
 
 empathy-chandler-glue.h: empathy-chandler.xml Makefile
        $(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=empathy_chandler --mode=glib-server --output=$@ $<
@@ -137,12 +160,19 @@ empathy-enum-types.c: $(libempathy_headers) Makefile
 
 dtddir = $(datadir)/empathy
 dtd_DATA =                                     \
-       empathy-chatroom-manager.dtd
+       empathy-status-presets.dtd              \
+       empathy-contact-groups.dtd              \
+       empathy-chatroom-manager.dtd            \
+       empathy-irc-networks.dtd
 
 stylesheetdir = $(datadir)/empathy
 stylesheet_DATA =              \
        empathy-log-manager.xsl
 
+ircnetworksdir = $(datadir)/empathy
+ircnetworks_DATA =             \
+       irc-networks.xml
+
 pkgconfigdir = $(libdir)/pkgconfig
 pkgconfig_DATA = libempathy.pc
 
@@ -150,8 +180,10 @@ EXTRA_DIST =                       \
        empathy-marshal.list    \
        empathy-chandler.xml    \
        empathy-filter.xml      \
+       tp-stream-engine.xml    \
        $(stylesheet_DATA)      \
-       $(dtd_DATA)
+       $(dtd_DATA)             \
+       $(ircnetworks_DATA)
 
 CLEANFILES =                           \
        $(BUILT_SOURCES)                \