]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
add empathy-pkg-kit
[empathy.git] / libempathy / Makefile.am
index 34a7061133ef73b28447adddcb5b5429b8267b42..6a6e2ce7e517ddf3bb44b92896c0ba96dd66cdb0 100644 (file)
@@ -16,13 +16,11 @@ AM_CPPFLAGS =                                           \
        $(NETWORK_MANAGER_CFLAGS)                       \
        $(CONNMAN_CFLAGS)                               \
        $(UDEV_CFLAGS)                                  \
+       $(GOA_CFLAGS)                                   \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
 BUILT_SOURCES =                                        \
-       empathy-marshal.h                               \
-       empathy-marshal.c                               \
-       empathy-marshal.list                            \
        empathy-enum-types.h                            \
        empathy-enum-types.c
 
@@ -38,9 +36,9 @@ libempathy_headers =                          \
        empathy-client-factory.h \
        empathy-connection-managers.h           \
        empathy-connectivity.h                  \
+       empathy-connection-aggregator.h         \
        empathy-contact-groups.h                \
        empathy-contact-list.h                  \
-       empathy-contact-manager.h               \
        empathy-contact.h                       \
        empathy-debug.h                         \
        empathy-ft-factory.h                    \
@@ -54,6 +52,7 @@ libempathy_headers =                          \
        empathy-keyring.h                       \
        empathy-location.h                      \
        empathy-message.h                       \
+       empathy-pkg-kit.h               \
        empathy-request-util.h                  \
        empathy-server-sasl-handler.h           \
        empathy-server-tls-handler.h            \
@@ -64,7 +63,6 @@ libempathy_headers =                          \
        empathy-tp-chat.h                       \
        empathy-tp-contact-factory.h            \
        empathy-tp-contact-list.h               \
-       empathy-tp-file.h                       \
        empathy-tp-roomlist.h                   \
        empathy-tp-streamed-media.h             \
        empathy-types.h                         \
@@ -81,9 +79,9 @@ libempathy_handwritten_source =                               \
        empathy-client-factory.c \
        empathy-connection-managers.c                   \
        empathy-connectivity.c                          \
+       empathy-connection-aggregator.c         \
        empathy-contact-groups.c                        \
        empathy-contact-list.c                          \
-       empathy-contact-manager.c                       \
        empathy-contact.c                               \
        empathy-debug.c                                 \
        empathy-ft-factory.c                            \
@@ -95,6 +93,7 @@ libempathy_handwritten_source =                               \
        empathy-irc-server.c                            \
        empathy-keyring.c                               \
        empathy-message.c                               \
+       empathy-pkg-kit.c               \
        empathy-request-util.c                          \
        empathy-server-sasl-handler.c                   \
        empathy-server-tls-handler.c                    \
@@ -105,15 +104,45 @@ libempathy_handwritten_source =                           \
        empathy-tp-chat.c                               \
        empathy-tp-contact-factory.c                    \
        empathy-tp-contact-list.c                       \
-       empathy-tp-file.c                               \
        empathy-tp-roomlist.c                           \
        empathy-tp-streamed-media.c                     \
        empathy-utils.c
 
+# these are sources that depend on GOA
+goa_sources = \
+       empathy-goa-auth-handler.c \
+       empathy-goa-auth-handler.h \
+       $(NULL)
+
 libempathy_la_SOURCES = \
        $(libempathy_handwritten_source) \
        cheese-camera-device-monitor.c cheese-camera-device-monitor.h
 
+dtddir = $(datadir)/empathy
+dtd_DATA =                                     \
+       empathy-status-presets.dtd              \
+       empathy-contact-groups.dtd              \
+       empathy-chatroom-manager.dtd            \
+       empathy-irc-networks.dtd
+
+ircnetworksdir = $(datadir)/empathy
+ircnetworks_DATA =             \
+       irc-networks.xml
+
+EXTRA_DIST =                   \
+       $(dtd_DATA)             \
+       $(ircnetworks_DATA)
+
+CLEANFILES =                           \
+       $(BUILT_SOURCES)                \
+       stamp-empathy-enum-types.h
+
+if HAVE_GOA
+libempathy_la_SOURCES += $(goa_sources)
+else
+EXTRA_DIST += $(goa_sources)
+endif
+
 # do not distribute generated files
 nodist_libempathy_la_SOURCES =\
        $(BUILT_SOURCES)
@@ -127,31 +156,18 @@ libempathy_la_LIBADD =            \
        $(GEOCODE_LIBS) \
        $(NETWORK_MANAGER_LIBS) \
        $(CONNMAN_LIBS) \
-       $(UDEV_LIBS)
+       $(UDEV_LIBS) \
+       $(GOA_LIBS) \
+       $(LIBM)
 
 check_c_sources = \
-    $(libempathy_handwritten_source)
+    $(libempathy_handwritten_source) \
+    $(goa_sources) \
+    $(NULL)
+
 include $(top_srcdir)/tools/check-coding-style.mk
 check-local: check-coding-style
 
-empathy-marshal.list: $(libempathy_la_SOURCES) Makefile.am
-       $(AM_V_GEN)( cd $(srcdir) && \
-       sed -n -e 's/.*empathy_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
-       $(libempathy_la_SOURCES) ) \
-       | sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
-       @if cmp -s $@.tmp $@; then \
-               rm $@.tmp; \
-       else \
-               mv $@.tmp $@; \
-       fi
-
-empathy-marshal.h: empathy-marshal.list Makefile
-       $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_empathy_marshal $< > empathy-marshal.h
-
-empathy-marshal.c: empathy-marshal.list Makefile
-       $(AM_V_GEN)echo "#include \"empathy-marshal.h\"" > $@ && \
-       $(GLIB_GENMARSHAL) --body --prefix=_empathy_marshal $< >> empathy-marshal.c
-
 empathy-enum-types.h: stamp-empathy-enum-types.h
        $(AM_V_GEN)true
 stamp-empathy-enum-types.h: $(libempathy_headers) Makefile
@@ -189,23 +205,3 @@ empathy-enum-types.c: $(libempathy_headers) Makefile
                $(libempathy_headers) ) > xgen-gtc \
        && cp xgen-gtc $(@F) \
        && rm -f xgen-gtc
-
-dtddir = $(datadir)/empathy
-dtd_DATA =                                     \
-       empathy-status-presets.dtd              \
-       empathy-contact-groups.dtd              \
-       empathy-chatroom-manager.dtd            \
-       empathy-irc-networks.dtd
-
-ircnetworksdir = $(datadir)/empathy
-ircnetworks_DATA =             \
-       irc-networks.xml
-
-EXTRA_DIST =                   \
-       empathy-marshal.list    \
-       $(dtd_DATA)             \
-       $(ircnetworks_DATA)
-
-CLEANFILES =                           \
-       $(BUILT_SOURCES)                \
-       stamp-empathy-enum-types.h