]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
add empathy-pkg-kit
[empathy.git] / libempathy / Makefile.am
index 2877dc6ae6a401b64a9a00bf6410d371267d511f..6a6e2ce7e517ddf3bb44b92896c0ba96dd66cdb0 100644 (file)
-include $(top_srcdir)/tools/shave.mk
 include $(top_srcdir)/tools/flymake.mk
 
 AM_CPPFLAGS =                                           \
+       $(ERROR_CFLAGS)                                 \
        -I.                                             \
        -I$(top_srcdir)                                 \
        -I$(top_builddir)                               \
        -DDATADIR=\""$(datadir)"\"                      \
        -DLOCALEDIR=\""$(datadir)/locale"\"             \
        -DG_LOG_DOMAIN=\"empathy\"                      \
-       $(LIBEMPATHY_CFLAGS)                            \
+       -DGCR_API_SUBJECT_TO_CHANGE                     \
+       $(EMPATHY_CFLAGS)                               \
+       $(YELL_CFLAGS)                                  \
        $(GEOCLUE_CFLAGS)                               \
-       $(NETWORK_MANAGER_CFLAGS) \
+       $(GEOCODE_CFLAGS)                               \
+       $(NETWORK_MANAGER_CFLAGS)                       \
+       $(CONNMAN_CFLAGS)                               \
+       $(UDEV_CFLAGS)                                  \
+       $(GOA_CFLAGS)                                   \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
 BUILT_SOURCES =                                        \
-       empathy-marshal.h                               \
-       empathy-marshal.c                               \
-       empathy-marshal.list                            \
        empathy-enum-types.h                            \
        empathy-enum-types.c
 
-lib_LTLIBRARIES = libempathy.la
+noinst_LTLIBRARIES = libempathy.la
 
-libempathy_la_SOURCES =                                        \
-       empathy-account-manager.c                       \
-       empathy-chatroom.c                              \
+libempathy_headers =                           \
+       action-chain-internal.h                 \
+       empathy-account-settings.h              \
+       empathy-auth-factory.h                  \
+       empathy-camera-monitor.h                \
+       empathy-chatroom-manager.h              \
+       empathy-chatroom.h                      \
+       empathy-client-factory.h \
+       empathy-connection-managers.h           \
+       empathy-connectivity.h                  \
+       empathy-connection-aggregator.h         \
+       empathy-contact-groups.h                \
+       empathy-contact-list.h                  \
+       empathy-contact.h                       \
+       empathy-debug.h                         \
+       empathy-ft-factory.h                    \
+       empathy-ft-handler.h                    \
+       empathy-gsettings.h                     \
+       empathy-presence-manager.h                              \
+       empathy-individual-manager.h            \
+       empathy-irc-network-manager.h           \
+       empathy-irc-network.h                   \
+       empathy-irc-server.h                    \
+       empathy-keyring.h                       \
+       empathy-location.h                      \
+       empathy-message.h                       \
+       empathy-pkg-kit.h               \
+       empathy-request-util.h                  \
+       empathy-server-sasl-handler.h           \
+       empathy-server-tls-handler.h            \
+       empathy-status-presets.h                \
+       empathy-time.h                          \
+       empathy-tls-certificate.h               \
+       empathy-tls-verifier.h                  \
+       empathy-tp-chat.h                       \
+       empathy-tp-contact-factory.h            \
+       empathy-tp-contact-list.h               \
+       empathy-tp-roomlist.h                   \
+       empathy-tp-streamed-media.h             \
+       empathy-types.h                         \
+       empathy-utils.h
+
+libempathy_handwritten_source =                                \
+       $(libempathy_headers)                           \
+       action-chain.c                                  \
+       empathy-account-settings.c                      \
+       empathy-auth-factory.c                          \
+       empathy-camera-monitor.c                        \
        empathy-chatroom-manager.c                      \
-       empathy-call-factory.c                          \
-       empathy-call-handler.c                          \
-       empathy-contact.c                               \
+       empathy-chatroom.c                              \
+       empathy-client-factory.c \
+       empathy-connection-managers.c                   \
+       empathy-connectivity.c                          \
+       empathy-connection-aggregator.c         \
        empathy-contact-groups.c                        \
        empathy-contact-list.c                          \
-       empathy-contact-manager.c                       \
-       empathy-contact-monitor.c                       \
+       empathy-contact.c                               \
        empathy-debug.c                                 \
-       empathy-debugger.c                              \
-       empathy-dispatcher.c                            \
-       empathy-dispatch-operation.c                    \
        empathy-ft-factory.c                            \
        empathy-ft-handler.c                            \
-       empathy-idle.c                                  \
-       empathy-irc-network.c                           \
+       empathy-presence-manager.c                                      \
+       empathy-individual-manager.c                    \
        empathy-irc-network-manager.c                   \
+       empathy-irc-network.c                           \
        empathy-irc-server.c                            \
-       empathy-log-manager.c                           \
-       empathy-log-store.c                             \
-       empathy-log-store-empathy.c                     \
+       empathy-keyring.c                               \
        empathy-message.c                               \
+       empathy-pkg-kit.c               \
+       empathy-request-util.c                          \
+       empathy-server-sasl-handler.c                   \
+       empathy-server-tls-handler.c                    \
        empathy-status-presets.c                        \
        empathy-time.c                                  \
-       empathy-tp-call.c                               \
+       empathy-tls-certificate.c                       \
+       empathy-tls-verifier.c                          \
        empathy-tp-chat.c                               \
        empathy-tp-contact-factory.c                    \
        empathy-tp-contact-list.c                       \
-       empathy-tp-file.c                               \
        empathy-tp-roomlist.c                           \
-       empathy-tube-handler.c                          \
+       empathy-tp-streamed-media.c                     \
        empathy-utils.c
 
+# these are sources that depend on GOA
+goa_sources = \
+       empathy-goa-auth-handler.c \
+       empathy-goa-auth-handler.h \
+       $(NULL)
+
+libempathy_la_SOURCES = \
+       $(libempathy_handwritten_source) \
+       cheese-camera-device-monitor.c cheese-camera-device-monitor.h
+
+dtddir = $(datadir)/empathy
+dtd_DATA =                                     \
+       empathy-status-presets.dtd              \
+       empathy-contact-groups.dtd              \
+       empathy-chatroom-manager.dtd            \
+       empathy-irc-networks.dtd
+
+ircnetworksdir = $(datadir)/empathy
+ircnetworks_DATA =             \
+       irc-networks.xml
+
+EXTRA_DIST =                   \
+       $(dtd_DATA)             \
+       $(ircnetworks_DATA)
+
+CLEANFILES =                           \
+       $(BUILT_SOURCES)                \
+       stamp-empathy-enum-types.h
+
+if HAVE_GOA
+libempathy_la_SOURCES += $(goa_sources)
+else
+EXTRA_DIST += $(goa_sources)
+endif
+
 # do not distribute generated files
 nodist_libempathy_la_SOURCES =\
        $(BUILT_SOURCES)
 
 libempathy_la_LIBADD =         \
        $(top_builddir)/extensions/libemp-extensions.la \
-       $(LIBEMPATHY_LIBS) \
+       $(top_builddir)/telepathy-yell/telepathy-yell/libtelepathy-yell.la \
+       $(GCR_LIBS) \
+       $(EMPATHY_LIBS) \
        $(GEOCLUE_LIBS) \
-       $(NETWORK_MANAGER_LIBS)
-
-libempathy_la_LDFLAGS =                \
-       -version-info ${LIBEMPATHY_CURRENT}:${LIBEMPATHY_REVISION}:${LIBEMPATHY_AGE} \
-       -export-symbols-regex ^empathy_
-
-libempathy_headers =                           \
-       empathy-account-manager.h               \
-       empathy-chatroom.h                      \
-       empathy-chatroom-manager.h              \
-       empathy-call-factory.h                  \
-       empathy-call-handler.h                  \
-       empathy-contact.h                       \
-       empathy-contact-groups.h                \
-       empathy-contact-list.h                  \
-       empathy-contact-manager.h               \
-       empathy-contact-monitor.h               \
-       empathy-debug.h                         \
-       empathy-debugger.h                      \
-       empathy-dispatcher.h                    \
-       empathy-dispatch-operation.h            \
-       empathy-ft-factory.h                    \
-       empathy-ft-handler.h                    \
-       empathy-idle.h                          \
-       empathy-irc-network.h                   \
-       empathy-irc-network-manager.h           \
-       empathy-irc-server.h                    \
-       empathy-location.h                      \
-       empathy-log-manager.h                   \
-       empathy-log-store.h                     \
-       empathy-log-store-empathy.h             \
-       empathy-message.h                       \
-       empathy-status-presets.h                \
-       empathy-time.h                          \
-       empathy-tp-call.h                       \
-       empathy-tp-chat.h                       \
-       empathy-tp-contact-factory.h            \
-       empathy-tp-contact-list.h               \
-       empathy-tp-file.h                       \
-       empathy-tp-roomlist.h                   \
-       empathy-tube-handler.h                  \
-       empathy-types.h                         \
-       empathy-utils.h
+       $(GEOCODE_LIBS) \
+       $(NETWORK_MANAGER_LIBS) \
+       $(CONNMAN_LIBS) \
+       $(UDEV_LIBS) \
+       $(GOA_LIBS) \
+       $(LIBM)
 
 check_c_sources = \
-    $(libempathy_la_SOURCES) \
-    $(libempathy_headers)
+    $(libempathy_handwritten_source) \
+    $(goa_sources) \
+    $(NULL)
+
 include $(top_srcdir)/tools/check-coding-style.mk
 check-local: check-coding-style
 
-libempathy_includedir = $(includedir)/libempathy/
-libempathy_include_HEADERS =                   \
-       $(libempathy_headers)                   \
-       empathy-enum-types.h
-
-empathy-marshal.list: $(libempathy_la_SOURCES) Makefile.am
-       $(QUIET_GEN)( cd $(srcdir) && \
-       sed -n -e 's/.*empathy_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
-       $(libempathy_la_SOURCES) ) \
-       | sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
-       if cmp -s $@.tmp $@; then \
-               rm $@.tmp; \
-       else \
-               mv $@.tmp $@; \
-       fi
-
-%-marshal.h: %-marshal.list Makefile
-       $(QUIET_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
-
-%-marshal.c: %-marshal.list Makefile
-       $(QUIET_GEN)echo "#include \"empathy-marshal.h\"" > $@ && \
-       $(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
-
 empathy-enum-types.h: stamp-empathy-enum-types.h
-       $(QUIET_GEN)true
+       $(AM_V_GEN)true
 stamp-empathy-enum-types.h: $(libempathy_headers) Makefile
-       $(QUIET_GEN)(cd $(srcdir) \
+       $(AM_V_GEN)(cd $(srcdir) \
        && glib-mkenums \
                        --fhead "#ifndef __LIBEMPATHY_ENUM_TYPES_H__\n" \
                        --fhead "#define __LIBEMPATHY_ENUM_TYPES_H__ 1\n\n" \
@@ -160,7 +188,7 @@ stamp-empathy-enum-types.h: $(libempathy_headers) Makefile
        && echo timestamp > $(@F)
 
 empathy-enum-types.c: $(libempathy_headers) Makefile
-       $(QUIET_GEN)(cd $(srcdir) \
+       $(AM_V_GEN)(cd $(srcdir) \
        && glib-mkenums \
                        --fhead "#include <config.h>\n" \
                        --fhead "#include <glib-object.h>\n" \
@@ -177,31 +205,3 @@ empathy-enum-types.c: $(libempathy_headers) Makefile
                $(libempathy_headers) ) > xgen-gtc \
        && cp xgen-gtc $(@F) \
        && rm -f xgen-gtc
-
-dtddir = $(datadir)/empathy
-dtd_DATA =                                     \
-       empathy-status-presets.dtd              \
-       empathy-contact-groups.dtd              \
-       empathy-chatroom-manager.dtd            \
-       empathy-irc-networks.dtd
-
-stylesheetdir = $(datadir)/empathy
-stylesheet_DATA =              \
-       empathy-log-manager.xsl
-
-ircnetworksdir = $(datadir)/empathy
-ircnetworks_DATA =             \
-       irc-networks.xml
-
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = libempathy.pc
-
-EXTRA_DIST =                   \
-       empathy-marshal.list    \
-       $(stylesheet_DATA)      \
-       $(dtd_DATA)             \
-       $(ircnetworks_DATA)
-
-CLEANFILES =                           \
-       $(BUILT_SOURCES)                \
-       stamp-empathy-enum-types.h