]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
Turn libempathy to a public lib
[empathy.git] / libempathy / Makefile.am
index ab7de6825e80c3c888e7e7cdc4984ab48443f15d..cfa525508d6fd6f0ac281a2b3314548ec08b5837 100644 (file)
@@ -23,8 +23,6 @@ BUILT_SOURCES =                                       \
        empathy-enum-types.h                            \
        empathy-enum-types.c
 
-noinst_LTLIBRARIES = libempathy.la
-
 libempathy_headers =                           \
        action-chain-internal.h                 \
        empathy-account-settings.h              \
@@ -99,10 +97,31 @@ goa_sources = \
        empathy-goa-auth-handler.h \
        $(NULL)
 
+pkglib_LTLIBRARIES = libempathy.la
+
+# libempathy's API is not stable and will never be, so use -release to make the
+# SONAME of the plugin library change with every Empathy release.
+libempathy_la_LDFLAGS = \
+   -no-undefined \
+   -release $(VERSION) \
+   $(NULL)
+
 libempathy_la_SOURCES = \
        $(libempathy_handwritten_source) \
        cheese-camera-device-monitor.c cheese-camera-device-monitor.h
 
+libempathy_la_LIBADD =         \
+       $(top_builddir)/extensions/libemp-extensions.la \
+       $(GCR_LIBS) \
+       $(EMPATHY_LIBS) \
+       $(GEOCLUE_LIBS) \
+       $(GEOCODE_LIBS) \
+       $(NETWORK_MANAGER_LIBS) \
+       $(CONNMAN_LIBS) \
+       $(UDEV_LIBS) \
+       $(GOA_LIBS) \
+       $(LIBM)
+
 dtddir = $(datadir)/empathy
 dtd_DATA =                                     \
        empathy-status-presets.dtd              \
@@ -132,18 +151,6 @@ endif
 nodist_libempathy_la_SOURCES =\
        $(BUILT_SOURCES)
 
-libempathy_la_LIBADD =         \
-       $(top_builddir)/extensions/libemp-extensions.la \
-       $(GCR_LIBS) \
-       $(EMPATHY_LIBS) \
-       $(GEOCLUE_LIBS) \
-       $(GEOCODE_LIBS) \
-       $(NETWORK_MANAGER_LIBS) \
-       $(CONNMAN_LIBS) \
-       $(UDEV_LIBS) \
-       $(GOA_LIBS) \
-       $(LIBM)
-
 check_c_sources = \
     $(libempathy_handwritten_source) \
     $(goa_sources) \