]> git.0d.be Git - empathy.git/blobdiff - libempathy-gtk/Makefile.am
Remove obsolete contact-list-{store,view}
[empathy.git] / libempathy-gtk / Makefile.am
index bb2565885a81d559dffc5d5e84b1c7b5daf463cc..e502736d3618564f4634bc805854547003d5e000 100644 (file)
@@ -8,20 +8,17 @@ AM_CPPFLAGS =                                           \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        -DGCR_API_SUBJECT_TO_CHANGE                     \
        $(EMPATHY_CFLAGS)                               \
+       $(YELL_CFLAGS)                                  \
        $(ENCHANT_CFLAGS)                               \
        $(LIBCHAMPLAIN_CFLAGS)                          \
        $(GEOCLUE_CFLAGS)                               \
        $(GEOCODE_CFLAGS)                               \
        $(MEEGO_CFLAGS)                                 \
-       $(WEBKIT_CFLAGS)                                \
        $(CHEESE_CFLAGS)                                \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
 BUILT_SOURCES =                                        \
-       empathy-gtk-marshal.h                           \
-       empathy-gtk-marshal.c                           \
-       empathy-gtk-marshal.list                        \
        empathy-gtk-enum-types.h                        \
        empathy-gtk-enum-types.c
 
@@ -29,12 +26,16 @@ noinst_LTLIBRARIES = libempathy-gtk.la
 
 libempathy_gtk_handwritten_source =                    \
        empathy-account-chooser.c               \
+       empathy-account-selector-dialog.c               \
        empathy-account-widget-irc.c            \
        empathy-account-widget-private.h        \
        empathy-account-widget-sip.c            \
        empathy-account-widget.c                \
        empathy-avatar-chooser.c                \
        empathy-avatar-image.c                  \
+       empathy-bad-password-dialog.c           \
+       empathy-base-password-dialog.c          \
+       empathy-call-utils.c                    \
        empathy-cell-renderer-activatable.c     \
        empathy-cell-renderer-expander.c        \
        empathy-cell-renderer-text.c            \
@@ -43,15 +44,14 @@ libempathy_gtk_handwritten_source =                 \
        empathy-chat.c                          \
        empathy-contact-blocking-dialog.c       \
        empathy-contact-dialogs.c               \
-       empathy-contact-list-store.c            \
-       empathy-contact-list-view.c             \
+       empathy-contact-chooser.c               \
        empathy-contact-menu.c                  \
+       empathy-contactinfo-utils.c             \
        empathy-linking-dialog.c                \
        empathy-live-search.c                   \
        empathy-contact-search-dialog.c         \
-       empathy-contact-selector.c              \
-       empathy-contact-selector-dialog.c \
        empathy-contact-widget.c                \
+       empathy-dialpad-widget.c                \
        empathy-geometry.c                      \
        empathy-groups-widget.c                 \
        empathy-individual-dialogs.c            \
@@ -60,6 +60,8 @@ libempathy_gtk_handwritten_source =                   \
        empathy-individual-linker.c             \
        empathy-individual-menu.c               \
        empathy-individual-store.c              \
+       empathy-individual-store-channel.c              \
+       empathy-individual-store-manager.c              \
        empathy-individual-view.c               \
        empathy-individual-widget.c             \
        empathy-input-text-view.c               \
@@ -86,15 +88,23 @@ libempathy_gtk_handwritten_source =                 \
        empathy-theme-irc.c                     \
        empathy-theme-manager.c                 \
        empathy-tls-dialog.c                    \
-       empathy-ui-utils.c
+       empathy-ui-utils.c                      \
+       empathy-plist.c                         \
+       empathy-theme-adium.c                   \
+       empathy-webkit-utils.c                  \
+       $(NULL)
 
 libempathy_gtk_headers =                       \
        empathy-account-chooser.h               \
+       empathy-account-selector-dialog.h               \
        empathy-account-widget-irc.h            \
        empathy-account-widget-sip.h            \
        empathy-account-widget.h                \
        empathy-avatar-chooser.h                \
        empathy-avatar-image.h                  \
+       empathy-bad-password-dialog.h           \
+       empathy-base-password-dialog.h          \
+       empathy-call-utils.h                    \
        empathy-cell-renderer-activatable.h     \
        empathy-cell-renderer-expander.h        \
        empathy-cell-renderer-text.h            \
@@ -103,15 +113,14 @@ libempathy_gtk_headers =                  \
        empathy-chat.h                          \
        empathy-contact-blocking-dialog.h       \
        empathy-contact-dialogs.h               \
-       empathy-contact-list-store.h            \
-       empathy-contact-list-view.h             \
+       empathy-contact-chooser.h               \
        empathy-contact-menu.h                  \
        empathy-linking-dialog.h                \
        empathy-live-search.h                   \
        empathy-contact-search-dialog.h         \
-       empathy-contact-selector.h              \
-       empathy-contact-selector-dialog.h \
        empathy-contact-widget.h                \
+       empathy-contactinfo-utils.h             \
+       empathy-dialpad-widget.h                \
        empathy-geometry.h                      \
        empathy-groups-widget.h                 \
        empathy-images.h                        \
@@ -121,6 +130,8 @@ libempathy_gtk_headers =                    \
        empathy-individual-linker.h             \
        empathy-individual-menu.h               \
        empathy-individual-store.h              \
+       empathy-individual-store-channel.h              \
+       empathy-individual-store-manager.h              \
        empathy-individual-view.h               \
        empathy-individual-widget.h             \
        empathy-input-text-view.h               \
@@ -147,7 +158,12 @@ libempathy_gtk_headers =                   \
        empathy-theme-irc.h                     \
        empathy-theme-manager.h                 \
        empathy-tls-dialog.h                    \
-       empathy-ui-utils.h
+       empathy-ui-utils.h                      \
+       empathy-plist.h                         \
+       empathy-theme-adium.h                   \
+       empathy-webkit-utils.h                  \
+       $(NULL)
+
 
 libempathy_gtk_la_SOURCES =                    \
        $(libempathy_gtk_handwritten_source)    \
@@ -159,6 +175,7 @@ nodist_libempathy_gtk_la_SOURCES =\
        $(BUILT_SOURCES)
 
 libempathy_gtk_la_LIBADD =                     \
+       $(EMPATHY_LIBS)                 \
        $(EMPATHY_LIBS)                 \
        $(GTK_LIBS)                     \
        $(LIBNOTIFY_LIBS)                       \
@@ -169,7 +186,6 @@ libempathy_gtk_la_LIBADD =                  \
        $(GEOCODE_LIBS)                         \
        $(GCR_LIBS)                             \
        $(MEEGO_LIBS)                           \
-       $(WEBKIT_LIBS)                          \
        $(CHEESE_LIBS)                          \
        $(top_builddir)/libempathy/libempathy.la
 
@@ -197,28 +213,9 @@ ui_DATA =                                  \
        empathy-status-preset-dialog.ui         \
        empathy-log-window.ui                   \
        empathy-chat.ui                         \
-       empathy-contact-selector-dialog.ui      \
        empathy-search-bar.ui                   \
        empathy-individual-widget.ui
 
-empathy-gtk-marshal.list: $(libempathy_gtk_la_SOURCES) Makefile.am
-       $(AM_V_GEN)( cd $(srcdir) && \
-       sed -n -e 's/.*empathy_gtk_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
-       $(libempathy_gtk_la_SOURCES) ) \
-       | sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
-       @if cmp -s $@.tmp $@; then \
-               rm $@.tmp; \
-       else \
-               mv $@.tmp $@; \
-       fi
-
-%-marshal.h: %-marshal.list Makefile
-       $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
-
-%-marshal.c: %-marshal.list Makefile
-       $(AM_V_GEN)echo "#include \"empathy-gtk-marshal.h\"" > $@ && \
-       $(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
-
 empathy-gtk-enum-types.h: stamp-empathy-gtk-enum-types.h
        $(AM_V_GEN)true
 stamp-empathy-gtk-enum-types.h: Makefile $(libempathy_gtk_headers)
@@ -272,21 +269,6 @@ EXTRA_DIST +=                                      \
        empathy-location-manager.h
 endif
 
-if HAVE_WEBKIT
-libempathy_gtk_handwritten_source +=           \
-       empathy-plist.c                         \
-       empathy-theme-adium.c
-libempathy_gtk_headers +=                      \
-       empathy-plist.h                         \
-       empathy-theme-adium.h
-else
-EXTRA_DIST +=                                  \
-       empathy-plist.c                         \
-       empathy-plist.h                         \
-       empathy-theme-adium.c                   \
-       empathy-theme-adium.h
-endif
-
 CLEANFILES =                           \
        $(BUILT_SOURCES)                \
        stamp-empathy-gtk-enum-types.h