]> git.0d.be Git - empathy.git/blobdiff - libempathy-gtk/Makefile.am
Remove obsolete contact-list-{store,view}
[empathy.git] / libempathy-gtk / Makefile.am
index 31e0ec8cc92cea413b2f1b50bcf8b9d861ff2423..e502736d3618564f4634bc805854547003d5e000 100644 (file)
@@ -19,9 +19,6 @@ AM_CPPFLAGS =                                           \
        $(DISABLE_DEPRECATED)
 
 BUILT_SOURCES =                                        \
-       empathy-gtk-marshal.h                           \
-       empathy-gtk-marshal.c                           \
-       empathy-gtk-marshal.list                        \
        empathy-gtk-enum-types.h                        \
        empathy-gtk-enum-types.c
 
@@ -36,6 +33,8 @@ libempathy_gtk_handwritten_source =                   \
        empathy-account-widget.c                \
        empathy-avatar-chooser.c                \
        empathy-avatar-image.c                  \
+       empathy-bad-password-dialog.c           \
+       empathy-base-password-dialog.c          \
        empathy-call-utils.c                    \
        empathy-cell-renderer-activatable.c     \
        empathy-cell-renderer-expander.c        \
@@ -46,15 +45,13 @@ libempathy_gtk_handwritten_source =                 \
        empathy-contact-blocking-dialog.c       \
        empathy-contact-dialogs.c               \
        empathy-contact-chooser.c               \
-       empathy-contact-list-store.c            \
-       empathy-contact-list-view.c             \
        empathy-contact-menu.c                  \
+       empathy-contactinfo-utils.c             \
        empathy-linking-dialog.c                \
        empathy-live-search.c                   \
        empathy-contact-search-dialog.c         \
-       empathy-contact-selector.c              \
-       empathy-contact-selector-dialog.c \
        empathy-contact-widget.c                \
+       empathy-dialpad-widget.c                \
        empathy-geometry.c                      \
        empathy-groups-widget.c                 \
        empathy-individual-dialogs.c            \
@@ -63,6 +60,8 @@ libempathy_gtk_handwritten_source =                   \
        empathy-individual-linker.c             \
        empathy-individual-menu.c               \
        empathy-individual-store.c              \
+       empathy-individual-store-channel.c              \
+       empathy-individual-store-manager.c              \
        empathy-individual-view.c               \
        empathy-individual-widget.c             \
        empathy-input-text-view.c               \
@@ -103,6 +102,8 @@ libempathy_gtk_headers =                    \
        empathy-account-widget.h                \
        empathy-avatar-chooser.h                \
        empathy-avatar-image.h                  \
+       empathy-bad-password-dialog.h           \
+       empathy-base-password-dialog.h          \
        empathy-call-utils.h                    \
        empathy-cell-renderer-activatable.h     \
        empathy-cell-renderer-expander.h        \
@@ -113,15 +114,13 @@ libempathy_gtk_headers =                  \
        empathy-contact-blocking-dialog.h       \
        empathy-contact-dialogs.h               \
        empathy-contact-chooser.h               \
-       empathy-contact-list-store.h            \
-       empathy-contact-list-view.h             \
        empathy-contact-menu.h                  \
        empathy-linking-dialog.h                \
        empathy-live-search.h                   \
        empathy-contact-search-dialog.h         \
-       empathy-contact-selector.h              \
-       empathy-contact-selector-dialog.h \
        empathy-contact-widget.h                \
+       empathy-contactinfo-utils.h             \
+       empathy-dialpad-widget.h                \
        empathy-geometry.h                      \
        empathy-groups-widget.h                 \
        empathy-images.h                        \
@@ -131,6 +130,8 @@ libempathy_gtk_headers =                    \
        empathy-individual-linker.h             \
        empathy-individual-menu.h               \
        empathy-individual-store.h              \
+       empathy-individual-store-channel.h              \
+       empathy-individual-store-manager.h              \
        empathy-individual-view.h               \
        empathy-individual-widget.h             \
        empathy-input-text-view.h               \
@@ -212,28 +213,9 @@ ui_DATA =                                  \
        empathy-status-preset-dialog.ui         \
        empathy-log-window.ui                   \
        empathy-chat.ui                         \
-       empathy-contact-selector-dialog.ui      \
        empathy-search-bar.ui                   \
        empathy-individual-widget.ui
 
-empathy-gtk-marshal.list: $(libempathy_gtk_la_SOURCES) Makefile.am
-       $(AM_V_GEN)( cd $(srcdir) && \
-       sed -n -e 's/.*empathy_gtk_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
-       $(libempathy_gtk_la_SOURCES) ) \
-       | sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
-       @if cmp -s $@.tmp $@; then \
-               rm $@.tmp; \
-       else \
-               mv $@.tmp $@; \
-       fi
-
-%-marshal.h: %-marshal.list Makefile
-       $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
-
-%-marshal.c: %-marshal.list Makefile
-       $(AM_V_GEN)echo "#include \"empathy-gtk-marshal.h\"" > $@ && \
-       $(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
-
 empathy-gtk-enum-types.h: stamp-empathy-gtk-enum-types.h
        $(AM_V_GEN)true
 stamp-empathy-gtk-enum-types.h: Makefile $(libempathy_gtk_headers)