]> git.0d.be Git - empathy.git/blobdiff - libempathy-gtk/Makefile.am
add empathy-local-xmpp-assistant-widget
[empathy.git] / libempathy-gtk / Makefile.am
index b45fc6e745f072b8f2b3118f1b3a30f02b51a3c6..c32448fa52f6faefed0e449eb209aeef36c4a0a9 100644 (file)
@@ -6,22 +6,20 @@ AM_CPPFLAGS =                                           \
        -I$(top_srcdir)                                 \
        -DDATADIR=\""$(datadir)"\"                      \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
+       -DGCR_API_SUBJECT_TO_CHANGE                     \
        $(EMPATHY_CFLAGS)                               \
-       $(GTK_CFLAGS)                           \
-       $(LIBNOTIFY_CFLAGS)                             \
-       $(CANBERRA_CFLAGS) \
+       $(YELL_CFLAGS)                                  \
        $(ENCHANT_CFLAGS)                               \
        $(LIBCHAMPLAIN_CFLAGS)                          \
        $(GEOCLUE_CFLAGS)                               \
-       $(MEEGO_CFLAGS)                         \
-       $(WEBKIT_CFLAGS)                                \
+       $(GEOCODE_CFLAGS)                               \
+       $(MEEGO_CFLAGS)                                 \
+       $(CHEESE_CFLAGS)                                \
+       $(EDS_CFLAGS)                                   \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
 BUILT_SOURCES =                                        \
-       empathy-gtk-marshal.h                           \
-       empathy-gtk-marshal.c                           \
-       empathy-gtk-marshal.list                        \
        empathy-gtk-enum-types.h                        \
        empathy-gtk-enum-types.c
 
@@ -29,109 +27,136 @@ noinst_LTLIBRARIES = libempathy-gtk.la
 
 libempathy_gtk_handwritten_source =                    \
        empathy-account-chooser.c               \
+       empathy-account-selector-dialog.c               \
        empathy-account-widget-irc.c            \
        empathy-account-widget-private.h        \
        empathy-account-widget-sip.c            \
        empathy-account-widget.c                \
-       empathy-audio-sink.c                    \
-       empathy-audio-src.c                     \
        empathy-avatar-chooser.c                \
        empathy-avatar-image.c                  \
+       empathy-bad-password-dialog.c           \
+       empathy-base-password-dialog.c          \
+       empathy-call-utils.c                    \
        empathy-cell-renderer-activatable.c     \
        empathy-cell-renderer-expander.c        \
        empathy-cell-renderer-text.c            \
        empathy-chat-text-view.c                \
        empathy-chat-view.c                     \
        empathy-chat.c                          \
+       empathy-contact-blocking-dialog.c       \
        empathy-contact-dialogs.c               \
-       empathy-contact-list-store.c            \
-       empathy-contact-list-view.c             \
-       empathy-contact-menu.c                  \
+       empathy-contact-chooser.c               \
+       empathy-contactinfo-utils.c             \
        empathy-live-search.c                   \
-       empathy-contact-selector.c              \
-       empathy-contact-selector-dialog.c \
+       empathy-contact-search-dialog.c         \
        empathy-contact-widget.c                \
+       empathy-dialpad-widget.c                \
        empathy-geometry.c                      \
+       empathy-groups-widget.c                 \
        empathy-individual-dialogs.c            \
+       empathy-individual-edit-dialog.c        \
        empathy-individual-menu.c               \
        empathy-individual-store.c              \
+       empathy-individual-store-channel.c              \
+       empathy-individual-store-manager.c              \
        empathy-individual-view.c               \
+       empathy-individual-widget.c             \
+       empathy-input-text-view.c               \
+       empathy-irc-network-chooser.c \
+       empathy-irc-network-chooser-dialog.c \
        empathy-irc-network-dialog.c            \
-       empathy-kludge-label.c                  \
+       empathy-local-xmpp-assistant-widget.c \
        empathy-log-window.c                    \
+       empathy-new-account-dialog.c            \
        empathy-new-message-dialog.c            \
        empathy-new-call-dialog.c               \
        empathy-notify-manager.c                \
-       empathy-persona-store.c                 \
-       empathy-persona-view.c                  \
+       empathy-password-dialog.c               \
        empathy-presence-chooser.c              \
        empathy-protocol-chooser.c              \
        empathy-search-bar.c                    \
        empathy-share-my-desktop.c              \
        empathy-smiley-manager.c                \
-       empathy-sound.c                         \
+       empathy-sound-manager.c                 \
        empathy-spell.c                         \
        empathy-status-preset-dialog.c          \
        empathy-string-parser.c                 \
        empathy-theme-boxes.c                   \
        empathy-theme-irc.c                     \
        empathy-theme-manager.c                 \
+       empathy-tls-dialog.c                    \
        empathy-ui-utils.c                      \
-       empathy-video-src.c                     \
-       empathy-video-widget.c
+       empathy-plist.c                         \
+       empathy-theme-adium.c                   \
+       empathy-webkit-utils.c                  \
+       $(NULL)
 
 libempathy_gtk_headers =                       \
        empathy-account-chooser.h               \
+       empathy-account-selector-dialog.h               \
        empathy-account-widget-irc.h            \
        empathy-account-widget-sip.h            \
        empathy-account-widget.h                \
-       empathy-audio-sink.h                    \
-       empathy-audio-src.h                     \
        empathy-avatar-chooser.h                \
        empathy-avatar-image.h                  \
+       empathy-bad-password-dialog.h           \
+       empathy-base-password-dialog.h          \
+       empathy-call-utils.h                    \
        empathy-cell-renderer-activatable.h     \
        empathy-cell-renderer-expander.h        \
        empathy-cell-renderer-text.h            \
        empathy-chat-text-view.h                \
        empathy-chat-view.h                     \
        empathy-chat.h                          \
+       empathy-contact-blocking-dialog.h       \
        empathy-contact-dialogs.h               \
-       empathy-contact-list-store.h            \
-       empathy-contact-list-view.h             \
-       empathy-contact-menu.h                  \
+       empathy-contact-chooser.h               \
        empathy-live-search.h                   \
-       empathy-contact-selector.h              \
-       empathy-contact-selector-dialog.h \
+       empathy-contact-search-dialog.h         \
        empathy-contact-widget.h                \
+       empathy-contactinfo-utils.h             \
+       empathy-dialpad-widget.h                \
        empathy-geometry.h                      \
+       empathy-groups-widget.h                 \
        empathy-images.h                        \
        empathy-individual-dialogs.h            \
+       empathy-individual-edit-dialog.h        \
        empathy-individual-menu.h               \
        empathy-individual-store.h              \
+       empathy-individual-store-channel.h              \
+       empathy-individual-store-manager.h              \
        empathy-individual-view.h               \
+       empathy-individual-widget.h             \
+       empathy-input-text-view.h               \
+       empathy-irc-network-chooser.h \
+       empathy-irc-network-chooser-dialog.h \
        empathy-irc-network-dialog.h            \
-       empathy-kludge-label.h                  \
+       empathy-local-xmpp-assistant-widget.h \
        empathy-log-window.h                    \
+       empathy-new-account-dialog.h            \
        empathy-new-message-dialog.h            \
        empathy-new-call-dialog.h               \
        empathy-notify-manager.h                \
-       empathy-persona-store.h                 \
-       empathy-persona-view.h                  \
+       empathy-password-dialog.h               \
        empathy-presence-chooser.h              \
        empathy-protocol-chooser.h              \
        empathy-search-bar.h                    \
        empathy-share-my-desktop.h              \
        empathy-smiley-manager.h                \
-       empathy-sound.h                         \
+       empathy-sound-manager.h                 \
        empathy-spell.h                         \
        empathy-status-preset-dialog.h          \
        empathy-string-parser.h                 \
        empathy-theme-boxes.h                   \
        empathy-theme-irc.h                     \
        empathy-theme-manager.h                 \
+       empathy-tls-dialog.h                    \
        empathy-ui-utils.h                      \
-       empathy-video-src.h                     \
-       empathy-video-widget.h
+       empathy-plist.h                         \
+       empathy-theme-adium.h                   \
+       empathy-webkit-utils.h                  \
+       $(NULL)
+
 
 libempathy_gtk_la_SOURCES =                    \
        $(libempathy_gtk_handwritten_source)    \
@@ -143,6 +168,7 @@ nodist_libempathy_gtk_la_SOURCES =\
        $(BUILT_SOURCES)
 
 libempathy_gtk_la_LIBADD =                     \
+       $(EMPATHY_LIBS)                 \
        $(EMPATHY_LIBS)                 \
        $(GTK_LIBS)                     \
        $(LIBNOTIFY_LIBS)                       \
@@ -150,8 +176,11 @@ libempathy_gtk_la_LIBADD =                 \
        $(ENCHANT_LIBS)                         \
        $(LIBCHAMPLAIN_LIBS)                    \
        $(GEOCLUE_LIBS)                         \
+       $(GEOCODE_LIBS)                         \
+       $(GCR_LIBS)                             \
        $(MEEGO_LIBS)                           \
-       $(WEBKIT_LIBS)                          \
+       $(CHEESE_LIBS)                          \
+       $(EDS_LIBS)                                     \
        $(top_builddir)/libempathy/libempathy.la
 
 check_c_sources = \
@@ -164,6 +193,7 @@ uidir = $(datadir)/empathy
 ui_DATA =                                      \
        empathy-contact-widget.ui               \
        empathy-contact-dialogs.ui              \
+       empathy-contact-blocking-dialog.ui      \
        empathy-account-widget-generic.ui       \
        empathy-account-widget-jabber.ui        \
        empathy-account-widget-msn.ui           \
@@ -177,26 +207,8 @@ ui_DATA =                                  \
        empathy-status-preset-dialog.ui         \
        empathy-log-window.ui                   \
        empathy-chat.ui                         \
-       empathy-contact-selector-dialog.ui      \
-       empathy-search-bar.ui
-
-empathy-gtk-marshal.list: $(libempathy_gtk_la_SOURCES) Makefile.am
-       $(AM_V_GEN)( cd $(srcdir) && \
-       sed -n -e 's/.*empathy_gtk_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
-       $(libempathy_gtk_la_SOURCES) ) \
-       | sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
-       @if cmp -s $@.tmp $@; then \
-               rm $@.tmp; \
-       else \
-               mv $@.tmp $@; \
-       fi
-
-%-marshal.h: %-marshal.list Makefile
-       $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
-
-%-marshal.c: %-marshal.list Makefile
-       $(AM_V_GEN)echo "#include \"empathy-gtk-marshal.h\"" > $@ && \
-       $(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
+       empathy-search-bar.ui                   \
+       empathy-individual-widget.ui
 
 empathy-gtk-enum-types.h: stamp-empathy-gtk-enum-types.h
        $(AM_V_GEN)true
@@ -251,21 +263,6 @@ EXTRA_DIST +=                                      \
        empathy-location-manager.h
 endif
 
-if HAVE_WEBKIT
-libempathy_gtk_handwritten_source +=           \
-       empathy-plist.c                         \
-       empathy-theme-adium.c
-libempathy_gtk_headers +=                      \
-       empathy-plist.h                         \
-       empathy-theme-adium.h
-else
-EXTRA_DIST +=                                  \
-       empathy-plist.c                         \
-       empathy-plist.h                         \
-       empathy-theme-adium.c                   \
-       empathy-theme-adium.h
-endif
-
 CLEANFILES =                           \
        $(BUILT_SOURCES)                \
        stamp-empathy-gtk-enum-types.h