]> git.0d.be Git - empathy.git/blobdiff - libempathy-gtk/Makefile.am
add empathy-local-xmpp-assistant-widget
[empathy.git] / libempathy-gtk / Makefile.am
index 7023ecfe53e004f5f61dc50bb4c978648b206369..c32448fa52f6faefed0e449eb209aeef36c4a0a9 100644 (file)
@@ -14,15 +14,12 @@ AM_CPPFLAGS =                                           \
        $(GEOCLUE_CFLAGS)                               \
        $(GEOCODE_CFLAGS)                               \
        $(MEEGO_CFLAGS)                                 \
-       $(WEBKIT_CFLAGS)                                \
        $(CHEESE_CFLAGS)                                \
+       $(EDS_CFLAGS)                                   \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
 BUILT_SOURCES =                                        \
-       empathy-gtk-marshal.h                           \
-       empathy-gtk-marshal.c                           \
-       empathy-gtk-marshal.list                        \
        empathy-gtk-enum-types.h                        \
        empathy-gtk-enum-types.c
 
@@ -30,12 +27,15 @@ noinst_LTLIBRARIES = libempathy-gtk.la
 
 libempathy_gtk_handwritten_source =                    \
        empathy-account-chooser.c               \
+       empathy-account-selector-dialog.c               \
        empathy-account-widget-irc.c            \
        empathy-account-widget-private.h        \
        empathy-account-widget-sip.c            \
        empathy-account-widget.c                \
        empathy-avatar-chooser.c                \
        empathy-avatar-image.c                  \
+       empathy-bad-password-dialog.c           \
+       empathy-base-password-dialog.c          \
        empathy-call-utils.c                    \
        empathy-cell-renderer-activatable.c     \
        empathy-cell-renderer-expander.c        \
@@ -45,36 +45,33 @@ libempathy_gtk_handwritten_source =                 \
        empathy-chat.c                          \
        empathy-contact-blocking-dialog.c       \
        empathy-contact-dialogs.c               \
-       empathy-contact-list-store.c            \
-       empathy-contact-list-view.c             \
-       empathy-contact-menu.c                  \
-       empathy-linking-dialog.c                \
+       empathy-contact-chooser.c               \
+       empathy-contactinfo-utils.c             \
        empathy-live-search.c                   \
        empathy-contact-search-dialog.c         \
-       empathy-contact-selector.c              \
-       empathy-contact-selector-dialog.c \
        empathy-contact-widget.c                \
+       empathy-dialpad-widget.c                \
        empathy-geometry.c                      \
        empathy-groups-widget.c                 \
        empathy-individual-dialogs.c            \
        empathy-individual-edit-dialog.c        \
-       empathy-individual-information-dialog.c \
-       empathy-individual-linker.c             \
        empathy-individual-menu.c               \
        empathy-individual-store.c              \
+       empathy-individual-store-channel.c              \
+       empathy-individual-store-manager.c              \
        empathy-individual-view.c               \
        empathy-individual-widget.c             \
        empathy-input-text-view.c               \
        empathy-irc-network-chooser.c \
        empathy-irc-network-chooser-dialog.c \
        empathy-irc-network-dialog.c            \
+       empathy-local-xmpp-assistant-widget.c \
        empathy-log-window.c                    \
+       empathy-new-account-dialog.c            \
        empathy-new-message-dialog.c            \
        empathy-new-call-dialog.c               \
        empathy-notify-manager.c                \
        empathy-password-dialog.c               \
-       empathy-persona-store.c                 \
-       empathy-persona-view.c                  \
        empathy-presence-chooser.c              \
        empathy-protocol-chooser.c              \
        empathy-search-bar.c                    \
@@ -88,15 +85,22 @@ libempathy_gtk_handwritten_source =                 \
        empathy-theme-irc.c                     \
        empathy-theme-manager.c                 \
        empathy-tls-dialog.c                    \
-       empathy-ui-utils.c
+       empathy-ui-utils.c                      \
+       empathy-plist.c                         \
+       empathy-theme-adium.c                   \
+       empathy-webkit-utils.c                  \
+       $(NULL)
 
 libempathy_gtk_headers =                       \
        empathy-account-chooser.h               \
+       empathy-account-selector-dialog.h               \
        empathy-account-widget-irc.h            \
        empathy-account-widget-sip.h            \
        empathy-account-widget.h                \
        empathy-avatar-chooser.h                \
        empathy-avatar-image.h                  \
+       empathy-bad-password-dialog.h           \
+       empathy-base-password-dialog.h          \
        empathy-call-utils.h                    \
        empathy-cell-renderer-activatable.h     \
        empathy-cell-renderer-expander.h        \
@@ -106,37 +110,34 @@ libempathy_gtk_headers =                  \
        empathy-chat.h                          \
        empathy-contact-blocking-dialog.h       \
        empathy-contact-dialogs.h               \
-       empathy-contact-list-store.h            \
-       empathy-contact-list-view.h             \
-       empathy-contact-menu.h                  \
-       empathy-linking-dialog.h                \
+       empathy-contact-chooser.h               \
        empathy-live-search.h                   \
        empathy-contact-search-dialog.h         \
-       empathy-contact-selector.h              \
-       empathy-contact-selector-dialog.h \
        empathy-contact-widget.h                \
+       empathy-contactinfo-utils.h             \
+       empathy-dialpad-widget.h                \
        empathy-geometry.h                      \
        empathy-groups-widget.h                 \
        empathy-images.h                        \
        empathy-individual-dialogs.h            \
        empathy-individual-edit-dialog.h        \
-       empathy-individual-information-dialog.h \
-       empathy-individual-linker.h             \
        empathy-individual-menu.h               \
        empathy-individual-store.h              \
+       empathy-individual-store-channel.h              \
+       empathy-individual-store-manager.h              \
        empathy-individual-view.h               \
        empathy-individual-widget.h             \
        empathy-input-text-view.h               \
        empathy-irc-network-chooser.h \
        empathy-irc-network-chooser-dialog.h \
        empathy-irc-network-dialog.h            \
+       empathy-local-xmpp-assistant-widget.h \
        empathy-log-window.h                    \
+       empathy-new-account-dialog.h            \
        empathy-new-message-dialog.h            \
        empathy-new-call-dialog.h               \
        empathy-notify-manager.h                \
        empathy-password-dialog.h               \
-       empathy-persona-store.h                 \
-       empathy-persona-view.h                  \
        empathy-presence-chooser.h              \
        empathy-protocol-chooser.h              \
        empathy-search-bar.h                    \
@@ -150,7 +151,12 @@ libempathy_gtk_headers =                   \
        empathy-theme-irc.h                     \
        empathy-theme-manager.h                 \
        empathy-tls-dialog.h                    \
-       empathy-ui-utils.h
+       empathy-ui-utils.h                      \
+       empathy-plist.h                         \
+       empathy-theme-adium.h                   \
+       empathy-webkit-utils.h                  \
+       $(NULL)
+
 
 libempathy_gtk_la_SOURCES =                    \
        $(libempathy_gtk_handwritten_source)    \
@@ -173,8 +179,8 @@ libempathy_gtk_la_LIBADD =                  \
        $(GEOCODE_LIBS)                         \
        $(GCR_LIBS)                             \
        $(MEEGO_LIBS)                           \
-       $(WEBKIT_LIBS)                          \
        $(CHEESE_LIBS)                          \
+       $(EDS_LIBS)                                     \
        $(top_builddir)/libempathy/libempathy.la
 
 check_c_sources = \
@@ -201,28 +207,9 @@ ui_DATA =                                  \
        empathy-status-preset-dialog.ui         \
        empathy-log-window.ui                   \
        empathy-chat.ui                         \
-       empathy-contact-selector-dialog.ui      \
        empathy-search-bar.ui                   \
        empathy-individual-widget.ui
 
-empathy-gtk-marshal.list: $(libempathy_gtk_la_SOURCES) Makefile.am
-       $(AM_V_GEN)( cd $(srcdir) && \
-       sed -n -e 's/.*empathy_gtk_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
-       $(libempathy_gtk_la_SOURCES) ) \
-       | sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
-       @if cmp -s $@.tmp $@; then \
-               rm $@.tmp; \
-       else \
-               mv $@.tmp $@; \
-       fi
-
-%-marshal.h: %-marshal.list Makefile
-       $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
-
-%-marshal.c: %-marshal.list Makefile
-       $(AM_V_GEN)echo "#include \"empathy-gtk-marshal.h\"" > $@ && \
-       $(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
-
 empathy-gtk-enum-types.h: stamp-empathy-gtk-enum-types.h
        $(AM_V_GEN)true
 stamp-empathy-gtk-enum-types.h: Makefile $(libempathy_gtk_headers)
@@ -276,21 +263,6 @@ EXTRA_DIST +=                                      \
        empathy-location-manager.h
 endif
 
-if HAVE_WEBKIT
-libempathy_gtk_handwritten_source +=           \
-       empathy-plist.c                         \
-       empathy-theme-adium.c
-libempathy_gtk_headers +=                      \
-       empathy-plist.h                         \
-       empathy-theme-adium.h
-else
-EXTRA_DIST +=                                  \
-       empathy-plist.c                         \
-       empathy-plist.h                         \
-       empathy-theme-adium.c                   \
-       empathy-theme-adium.h
-endif
-
 CLEANFILES =                           \
        $(BUILT_SOURCES)                \
        stamp-empathy-gtk-enum-types.h