]> git.0d.be Git - empathy.git/blobdiff - libempathy-gtk/Makefile.am
Merge branch 'log-window-webview'
[empathy.git] / libempathy-gtk / Makefile.am
index bb2565885a81d559dffc5d5e84b1c7b5daf463cc..33dcbfb9332d954d27c72b2bb326fa4bc4d03778 100644 (file)
@@ -8,12 +8,12 @@ AM_CPPFLAGS =                                           \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        -DGCR_API_SUBJECT_TO_CHANGE                     \
        $(EMPATHY_CFLAGS)                               \
+       $(YELL_CFLAGS)                                  \
        $(ENCHANT_CFLAGS)                               \
        $(LIBCHAMPLAIN_CFLAGS)                          \
        $(GEOCLUE_CFLAGS)                               \
        $(GEOCODE_CFLAGS)                               \
        $(MEEGO_CFLAGS)                                 \
-       $(WEBKIT_CFLAGS)                                \
        $(CHEESE_CFLAGS)                                \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
@@ -35,6 +35,7 @@ libempathy_gtk_handwritten_source =                   \
        empathy-account-widget.c                \
        empathy-avatar-chooser.c                \
        empathy-avatar-image.c                  \
+       empathy-call-utils.c                    \
        empathy-cell-renderer-activatable.c     \
        empathy-cell-renderer-expander.c        \
        empathy-cell-renderer-text.c            \
@@ -43,6 +44,7 @@ libempathy_gtk_handwritten_source =                   \
        empathy-chat.c                          \
        empathy-contact-blocking-dialog.c       \
        empathy-contact-dialogs.c               \
+       empathy-contact-chooser.c               \
        empathy-contact-list-store.c            \
        empathy-contact-list-view.c             \
        empathy-contact-menu.c                  \
@@ -86,7 +88,11 @@ libempathy_gtk_handwritten_source =                  \
        empathy-theme-irc.c                     \
        empathy-theme-manager.c                 \
        empathy-tls-dialog.c                    \
-       empathy-ui-utils.c
+       empathy-ui-utils.c                      \
+       empathy-plist.c                         \
+       empathy-theme-adium.c                   \
+       empathy-webkit-utils.c                  \
+       $(NULL)
 
 libempathy_gtk_headers =                       \
        empathy-account-chooser.h               \
@@ -95,6 +101,7 @@ libempathy_gtk_headers =                     \
        empathy-account-widget.h                \
        empathy-avatar-chooser.h                \
        empathy-avatar-image.h                  \
+       empathy-call-utils.h                    \
        empathy-cell-renderer-activatable.h     \
        empathy-cell-renderer-expander.h        \
        empathy-cell-renderer-text.h            \
@@ -103,6 +110,7 @@ libempathy_gtk_headers =                    \
        empathy-chat.h                          \
        empathy-contact-blocking-dialog.h       \
        empathy-contact-dialogs.h               \
+       empathy-contact-chooser.h               \
        empathy-contact-list-store.h            \
        empathy-contact-list-view.h             \
        empathy-contact-menu.h                  \
@@ -147,7 +155,12 @@ libempathy_gtk_headers =                   \
        empathy-theme-irc.h                     \
        empathy-theme-manager.h                 \
        empathy-tls-dialog.h                    \
-       empathy-ui-utils.h
+       empathy-ui-utils.h                      \
+       empathy-plist.h                         \
+       empathy-theme-adium.h                   \
+       empathy-webkit-utils.h                  \
+       $(NULL)
+
 
 libempathy_gtk_la_SOURCES =                    \
        $(libempathy_gtk_handwritten_source)    \
@@ -159,6 +172,7 @@ nodist_libempathy_gtk_la_SOURCES =\
        $(BUILT_SOURCES)
 
 libempathy_gtk_la_LIBADD =                     \
+       $(EMPATHY_LIBS)                 \
        $(EMPATHY_LIBS)                 \
        $(GTK_LIBS)                     \
        $(LIBNOTIFY_LIBS)                       \
@@ -169,7 +183,6 @@ libempathy_gtk_la_LIBADD =                  \
        $(GEOCODE_LIBS)                         \
        $(GCR_LIBS)                             \
        $(MEEGO_LIBS)                           \
-       $(WEBKIT_LIBS)                          \
        $(CHEESE_LIBS)                          \
        $(top_builddir)/libempathy/libempathy.la
 
@@ -272,21 +285,6 @@ EXTRA_DIST +=                                      \
        empathy-location-manager.h
 endif
 
-if HAVE_WEBKIT
-libempathy_gtk_handwritten_source +=           \
-       empathy-plist.c                         \
-       empathy-theme-adium.c
-libempathy_gtk_headers +=                      \
-       empathy-plist.h                         \
-       empathy-theme-adium.h
-else
-EXTRA_DIST +=                                  \
-       empathy-plist.c                         \
-       empathy-plist.h                         \
-       empathy-theme-adium.c                   \
-       empathy-theme-adium.h
-endif
-
 CLEANFILES =                           \
        $(BUILT_SOURCES)                \
        stamp-empathy-gtk-enum-types.h