]> git.0d.be Git - empathy.git/blobdiff - libempathy-gtk/Makefile.am
Merge branch 'log-window-webview'
[empathy.git] / libempathy-gtk / Makefile.am
index 72e489c75dd94fbc678da173587fc34e661f979d..33dcbfb9332d954d27c72b2bb326fa4bc4d03778 100644 (file)
@@ -8,11 +8,13 @@ AM_CPPFLAGS =                                           \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        -DGCR_API_SUBJECT_TO_CHANGE                     \
        $(EMPATHY_CFLAGS)                               \
+       $(YELL_CFLAGS)                                  \
        $(ENCHANT_CFLAGS)                               \
        $(LIBCHAMPLAIN_CFLAGS)                          \
        $(GEOCLUE_CFLAGS)                               \
+       $(GEOCODE_CFLAGS)                               \
        $(MEEGO_CFLAGS)                                 \
-       $(WEBKIT_CFLAGS)                                \
+       $(CHEESE_CFLAGS)                                \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
@@ -31,22 +33,24 @@ libempathy_gtk_handwritten_source =                 \
        empathy-account-widget-private.h        \
        empathy-account-widget-sip.c            \
        empathy-account-widget.c                \
-       empathy-audio-sink.c                    \
-       empathy-audio-src.c                     \
        empathy-avatar-chooser.c                \
        empathy-avatar-image.c                  \
+       empathy-call-utils.c                    \
        empathy-cell-renderer-activatable.c     \
        empathy-cell-renderer-expander.c        \
        empathy-cell-renderer-text.c            \
        empathy-chat-text-view.c                \
        empathy-chat-view.c                     \
        empathy-chat.c                          \
+       empathy-contact-blocking-dialog.c       \
        empathy-contact-dialogs.c               \
+       empathy-contact-chooser.c               \
        empathy-contact-list-store.c            \
        empathy-contact-list-view.c             \
        empathy-contact-menu.c                  \
        empathy-linking-dialog.c                \
        empathy-live-search.c                   \
+       empathy-contact-search-dialog.c         \
        empathy-contact-selector.c              \
        empathy-contact-selector-dialog.c \
        empathy-contact-widget.c                \
@@ -85,30 +89,34 @@ libempathy_gtk_handwritten_source =                 \
        empathy-theme-manager.c                 \
        empathy-tls-dialog.c                    \
        empathy-ui-utils.c                      \
-       empathy-video-src.c                     \
-       empathy-video-widget.c
+       empathy-plist.c                         \
+       empathy-theme-adium.c                   \
+       empathy-webkit-utils.c                  \
+       $(NULL)
 
 libempathy_gtk_headers =                       \
        empathy-account-chooser.h               \
        empathy-account-widget-irc.h            \
        empathy-account-widget-sip.h            \
        empathy-account-widget.h                \
-       empathy-audio-sink.h                    \
-       empathy-audio-src.h                     \
        empathy-avatar-chooser.h                \
        empathy-avatar-image.h                  \
+       empathy-call-utils.h                    \
        empathy-cell-renderer-activatable.h     \
        empathy-cell-renderer-expander.h        \
        empathy-cell-renderer-text.h            \
        empathy-chat-text-view.h                \
        empathy-chat-view.h                     \
        empathy-chat.h                          \
+       empathy-contact-blocking-dialog.h       \
        empathy-contact-dialogs.h               \
+       empathy-contact-chooser.h               \
        empathy-contact-list-store.h            \
        empathy-contact-list-view.h             \
        empathy-contact-menu.h                  \
        empathy-linking-dialog.h                \
        empathy-live-search.h                   \
+       empathy-contact-search-dialog.h         \
        empathy-contact-selector.h              \
        empathy-contact-selector-dialog.h \
        empathy-contact-widget.h                \
@@ -148,13 +156,15 @@ libempathy_gtk_headers =                  \
        empathy-theme-manager.h                 \
        empathy-tls-dialog.h                    \
        empathy-ui-utils.h                      \
-       empathy-video-src.h                     \
-       empathy-video-widget.h
+       empathy-plist.h                         \
+       empathy-theme-adium.h                   \
+       empathy-webkit-utils.h                  \
+       $(NULL)
+
 
 libempathy_gtk_la_SOURCES =                    \
        $(libempathy_gtk_handwritten_source)    \
        $(libempathy_gtk_headers)               \
-       gcr-simple-certificate.c gcr-simple-certificate.h \
        totem-subtitle-encoding.c totem-subtitle-encoding.h
 
 # do not distribute generated files
@@ -162,6 +172,7 @@ nodist_libempathy_gtk_la_SOURCES =\
        $(BUILT_SOURCES)
 
 libempathy_gtk_la_LIBADD =                     \
+       $(EMPATHY_LIBS)                 \
        $(EMPATHY_LIBS)                 \
        $(GTK_LIBS)                     \
        $(LIBNOTIFY_LIBS)                       \
@@ -169,9 +180,10 @@ libempathy_gtk_la_LIBADD =                 \
        $(ENCHANT_LIBS)                         \
        $(LIBCHAMPLAIN_LIBS)                    \
        $(GEOCLUE_LIBS)                         \
+       $(GEOCODE_LIBS)                         \
        $(GCR_LIBS)                             \
        $(MEEGO_LIBS)                           \
-       $(WEBKIT_LIBS)                          \
+       $(CHEESE_LIBS)                          \
        $(top_builddir)/libempathy/libempathy.la
 
 check_c_sources = \
@@ -184,6 +196,7 @@ uidir = $(datadir)/empathy
 ui_DATA =                                      \
        empathy-contact-widget.ui               \
        empathy-contact-dialogs.ui              \
+       empathy-contact-blocking-dialog.ui      \
        empathy-account-widget-generic.ui       \
        empathy-account-widget-jabber.ui        \
        empathy-account-widget-msn.ui           \
@@ -272,21 +285,6 @@ EXTRA_DIST +=                                      \
        empathy-location-manager.h
 endif
 
-if HAVE_WEBKIT
-libempathy_gtk_handwritten_source +=           \
-       empathy-plist.c                         \
-       empathy-theme-adium.c
-libempathy_gtk_headers +=                      \
-       empathy-plist.h                         \
-       empathy-theme-adium.h
-else
-EXTRA_DIST +=                                  \
-       empathy-plist.c                         \
-       empathy-plist.h                         \
-       empathy-theme-adium.c                   \
-       empathy-theme-adium.h
-endif
-
 CLEANFILES =                           \
        $(BUILT_SOURCES)                \
        stamp-empathy-gtk-enum-types.h