]> git.0d.be Git - empathy.git/blobdiff - libempathy-gtk/Makefile.am
Merge branch 'log-window-webview'
[empathy.git] / libempathy-gtk / Makefile.am
index 5903efb15daf37864c749eabfc63b6a43df7500a..33dcbfb9332d954d27c72b2bb326fa4bc4d03778 100644 (file)
@@ -1,16 +1,20 @@
-include $(top_srcdir)/tools/shave.mk
 include $(top_srcdir)/tools/flymake.mk
 
 AM_CPPFLAGS =                                           \
+       $(ERROR_CFLAGS)                                 \
        -I.                                             \
        -I$(top_srcdir)                                 \
        -DDATADIR=\""$(datadir)"\"                      \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
-       $(LIBEMPATHYGTK_CFLAGS)                         \
+       -DGCR_API_SUBJECT_TO_CHANGE                     \
+       $(EMPATHY_CFLAGS)                               \
+       $(YELL_CFLAGS)                                  \
        $(ENCHANT_CFLAGS)                               \
        $(LIBCHAMPLAIN_CFLAGS)                          \
        $(GEOCLUE_CFLAGS)                               \
-       $(WEBKIT_CFLAGS)                                \
+       $(GEOCODE_CFLAGS)                               \
+       $(MEEGO_CFLAGS)                                 \
+       $(CHEESE_CFLAGS)                                \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
@@ -21,108 +25,166 @@ BUILT_SOURCES =                                   \
        empathy-gtk-enum-types.h                        \
        empathy-gtk-enum-types.c
 
-lib_LTLIBRARIES = libempathy-gtk.la
+noinst_LTLIBRARIES = libempathy-gtk.la
 
 libempathy_gtk_handwritten_source =                    \
        empathy-account-chooser.c               \
-       empathy-account-widget.c                \
        empathy-account-widget-irc.c            \
+       empathy-account-widget-private.h        \
        empathy-account-widget-sip.c            \
+       empathy-account-widget.c                \
        empathy-avatar-chooser.c                \
        empathy-avatar-image.c                  \
+       empathy-call-utils.c                    \
        empathy-cell-renderer-activatable.c     \
        empathy-cell-renderer-expander.c        \
        empathy-cell-renderer-text.c            \
-       empathy-chat.c                          \
        empathy-chat-text-view.c                \
        empathy-chat-view.c                     \
-       empathy-conf.c                          \
+       empathy-chat.c                          \
+       empathy-contact-blocking-dialog.c       \
        empathy-contact-dialogs.c               \
+       empathy-contact-chooser.c               \
        empathy-contact-list-store.c            \
        empathy-contact-list-view.c             \
        empathy-contact-menu.c                  \
+       empathy-linking-dialog.c                \
+       empathy-live-search.c                   \
+       empathy-contact-search-dialog.c         \
        empathy-contact-selector.c              \
+       empathy-contact-selector-dialog.c \
        empathy-contact-widget.c                \
        empathy-geometry.c                      \
-       empathy-audio-sink.c                    \
-       empathy-audio-src.c                     \
-       empathy-video-src.c                     \
-       empathy-video-widget.c                  \
+       empathy-groups-widget.c                 \
+       empathy-individual-dialogs.c            \
+       empathy-individual-edit-dialog.c        \
+       empathy-individual-information-dialog.c \
+       empathy-individual-linker.c             \
+       empathy-individual-menu.c               \
+       empathy-individual-store.c              \
+       empathy-individual-view.c               \
+       empathy-individual-widget.c             \
+       empathy-input-text-view.c               \
+       empathy-irc-network-chooser.c \
+       empathy-irc-network-chooser-dialog.c \
        empathy-irc-network-dialog.c            \
        empathy-log-window.c                    \
        empathy-new-message-dialog.c            \
+       empathy-new-call-dialog.c               \
+       empathy-notify-manager.c                \
+       empathy-password-dialog.c               \
+       empathy-persona-store.c                 \
+       empathy-persona-view.c                  \
        empathy-presence-chooser.c              \
-       empathy-profile-chooser.c               \
+       empathy-protocol-chooser.c              \
+       empathy-search-bar.c                    \
+       empathy-share-my-desktop.c              \
        empathy-smiley-manager.c                \
-       empathy-sound.c                         \
+       empathy-sound-manager.c                 \
        empathy-spell.c                         \
        empathy-status-preset-dialog.c          \
+       empathy-string-parser.c                 \
        empathy-theme-boxes.c                   \
        empathy-theme-irc.c                     \
        empathy-theme-manager.c                 \
-       empathy-kludge-label.c                  \
-       empathy-ui-utils.c
-
-libempathy_gtk_la_SOURCES =                    \
-       $(libempathy_gtk_handwritten_source)    \
-       totem-subtitle-encoding.c totem-subtitle-encoding.h
-
-# do not distribute generated files
-nodist_libempathy_gtk_la_SOURCES =\
-       $(BUILT_SOURCES)
-
-libempathy_gtk_la_LIBADD =                     \
-       $(LIBEMPATHYGTK_LIBS)                   \
-       $(ENCHANT_LIBS)                         \
-       $(LIBCHAMPLAIN_LIBS)                    \
-       $(GEOCLUE_LIBS)                         \
-       $(WEBKIT_LIBS)                          \
-       $(top_builddir)/libempathy/libempathy.la
-
-libempathy_gtk_la_LDFLAGS =                \
-       -version-info ${LIBEMPATHY_GTK_CURRENT}:${LIBEMPATHY_GTK_REVISION}:${LIBEMPATHY_GTK_AGE} \
-       -export-symbols-regex ^empathy_
+       empathy-tls-dialog.c                    \
+       empathy-ui-utils.c                      \
+       empathy-plist.c                         \
+       empathy-theme-adium.c                   \
+       empathy-webkit-utils.c                  \
+       $(NULL)
 
 libempathy_gtk_headers =                       \
        empathy-account-chooser.h               \
-       empathy-account-widget.h                \
        empathy-account-widget-irc.h            \
        empathy-account-widget-sip.h            \
+       empathy-account-widget.h                \
        empathy-avatar-chooser.h                \
        empathy-avatar-image.h                  \
+       empathy-call-utils.h                    \
        empathy-cell-renderer-activatable.h     \
        empathy-cell-renderer-expander.h        \
        empathy-cell-renderer-text.h            \
-       empathy-chat.h                          \
        empathy-chat-text-view.h                \
        empathy-chat-view.h                     \
-       empathy-conf.h                          \
+       empathy-chat.h                          \
+       empathy-contact-blocking-dialog.h       \
        empathy-contact-dialogs.h               \
+       empathy-contact-chooser.h               \
        empathy-contact-list-store.h            \
        empathy-contact-list-view.h             \
        empathy-contact-menu.h                  \
+       empathy-linking-dialog.h                \
+       empathy-live-search.h                   \
+       empathy-contact-search-dialog.h         \
        empathy-contact-selector.h              \
+       empathy-contact-selector-dialog.h \
        empathy-contact-widget.h                \
        empathy-geometry.h                      \
-       empathy-audio-sink.h                    \
-       empathy-audio-src.h                     \
-       empathy-video-src.h                     \
-       empathy-video-widget.h                  \
+       empathy-groups-widget.h                 \
        empathy-images.h                        \
+       empathy-individual-dialogs.h            \
+       empathy-individual-edit-dialog.h        \
+       empathy-individual-information-dialog.h \
+       empathy-individual-linker.h             \
+       empathy-individual-menu.h               \
+       empathy-individual-store.h              \
+       empathy-individual-view.h               \
+       empathy-individual-widget.h             \
+       empathy-input-text-view.h               \
+       empathy-irc-network-chooser.h \
+       empathy-irc-network-chooser-dialog.h \
        empathy-irc-network-dialog.h            \
        empathy-log-window.h                    \
        empathy-new-message-dialog.h            \
+       empathy-new-call-dialog.h               \
+       empathy-notify-manager.h                \
+       empathy-password-dialog.h               \
+       empathy-persona-store.h                 \
+       empathy-persona-view.h                  \
        empathy-presence-chooser.h              \
-       empathy-profile-chooser.h               \
+       empathy-protocol-chooser.h              \
+       empathy-search-bar.h                    \
+       empathy-share-my-desktop.h              \
        empathy-smiley-manager.h                \
-       empathy-sound.h                         \
+       empathy-sound-manager.h                 \
        empathy-spell.h                         \
        empathy-status-preset-dialog.h          \
+       empathy-string-parser.h                 \
        empathy-theme-boxes.h                   \
        empathy-theme-irc.h                     \
        empathy-theme-manager.h                 \
-       empathy-kludge-label.h                  \
-       empathy-ui-utils.h
+       empathy-tls-dialog.h                    \
+       empathy-ui-utils.h                      \
+       empathy-plist.h                         \
+       empathy-theme-adium.h                   \
+       empathy-webkit-utils.h                  \
+       $(NULL)
+
+
+libempathy_gtk_la_SOURCES =                    \
+       $(libempathy_gtk_handwritten_source)    \
+       $(libempathy_gtk_headers)               \
+       totem-subtitle-encoding.c totem-subtitle-encoding.h
+
+# do not distribute generated files
+nodist_libempathy_gtk_la_SOURCES =\
+       $(BUILT_SOURCES)
+
+libempathy_gtk_la_LIBADD =                     \
+       $(EMPATHY_LIBS)                 \
+       $(EMPATHY_LIBS)                 \
+       $(GTK_LIBS)                     \
+       $(LIBNOTIFY_LIBS)                       \
+       $(CANBERRA_LIBS) \
+       $(ENCHANT_LIBS)                         \
+       $(LIBCHAMPLAIN_LIBS)                    \
+       $(GEOCLUE_LIBS)                         \
+       $(GEOCODE_LIBS)                         \
+       $(GCR_LIBS)                             \
+       $(MEEGO_LIBS)                           \
+       $(CHEESE_LIBS)                          \
+       $(top_builddir)/libempathy/libempathy.la
 
 check_c_sources = \
     $(libempathy_gtk_handwritten_source) \
@@ -130,20 +192,16 @@ check_c_sources = \
 include $(top_srcdir)/tools/check-coding-style.mk
 check-local: check-coding-style
 
-libempathy_gtk_includedir = $(includedir)/libempathy-gtk/
-libempathy_gtk_include_HEADERS =               \
-       $(libempathy_gtk_headers)               \
-       empathy-gtk-enum-types.h
-
 uidir = $(datadir)/empathy
 ui_DATA =                                      \
        empathy-contact-widget.ui               \
        empathy-contact-dialogs.ui              \
+       empathy-contact-blocking-dialog.ui      \
        empathy-account-widget-generic.ui       \
        empathy-account-widget-jabber.ui        \
        empathy-account-widget-msn.ui           \
        empathy-account-widget-sip.ui           \
-       empathy-account-widget-salut.ui         \
+       empathy-account-widget-local-xmpp.ui    \
        empathy-account-widget-irc.ui           \
        empathy-account-widget-icq.ui           \
        empathy-account-widget-yahoo.ui         \
@@ -152,30 +210,32 @@ ui_DATA =                                         \
        empathy-status-preset-dialog.ui         \
        empathy-log-window.ui                   \
        empathy-chat.ui                         \
-       empathy-new-message-dialog.ui
+       empathy-contact-selector-dialog.ui      \
+       empathy-search-bar.ui                   \
+       empathy-individual-widget.ui
 
 empathy-gtk-marshal.list: $(libempathy_gtk_la_SOURCES) Makefile.am
-       $(QUIET_GEN)( cd $(srcdir) && \
+       $(AM_V_GEN)( cd $(srcdir) && \
        sed -n -e 's/.*empathy_gtk_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
        $(libempathy_gtk_la_SOURCES) ) \
        | sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
-       if cmp -s $@.tmp $@; then \
+       @if cmp -s $@.tmp $@; then \
                rm $@.tmp; \
        else \
                mv $@.tmp $@; \
        fi
 
 %-marshal.h: %-marshal.list Makefile
-       $(QUIET_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
+       $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
 
 %-marshal.c: %-marshal.list Makefile
-       $(QUIET_GEN)echo "#include \"empathy-gtk-marshal.h\"" > $@ && \
+       $(AM_V_GEN)echo "#include \"empathy-gtk-marshal.h\"" > $@ && \
        $(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
 
 empathy-gtk-enum-types.h: stamp-empathy-gtk-enum-types.h
-       $(QUIET_GEN)true
+       $(AM_V_GEN)true
 stamp-empathy-gtk-enum-types.h: Makefile $(libempathy_gtk_headers)
-       $(QUIET_GEN)(cd $(srcdir) \
+       $(AM_V_GEN)(cd $(srcdir) \
        && glib-mkenums \
                        --fhead "#ifndef __LIBEMPATHY_GTK_ENUM_TYPES_H__\n" \
                        --fhead "#define __LIBEMPATHY_GTK_ENUM_TYPES_H__ 1\n\n" \
@@ -192,7 +252,7 @@ stamp-empathy-gtk-enum-types.h: Makefile $(libempathy_gtk_headers)
        && echo timestamp > $(@F)
 
 empathy-gtk-enum-types.c: Makefile $(libempathy_gtk_headers)
-       $(QUIET_GEN)(cd $(srcdir) \
+       $(AM_V_GEN)(cd $(srcdir) \
        && glib-mkenums \
                        --fhead "#include <config.h>\n" \
                        --fhead "#include <glib-object.h>\n" \
@@ -210,9 +270,6 @@ empathy-gtk-enum-types.c: Makefile $(libempathy_gtk_headers)
        && cp xgen-gtc $(@F) \
        && rm -f xgen-gtc
 
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = libempathy-gtk.pc
-
 EXTRA_DIST =                   \
        $(ui_DATA)
 
@@ -228,21 +285,6 @@ EXTRA_DIST +=                                      \
        empathy-location-manager.h
 endif
 
-if HAVE_WEBKIT
-libempathy_gtk_handwritten_source +=           \
-       empathy-plist.c                         \
-       empathy-theme-adium.c
-libempathy_gtk_headers +=                      \
-       empathy-plist.h                         \
-       empathy-theme-adium.h
-else
-EXTRA_DIST +=                                  \
-       empathy-plist.c                         \
-       empathy-plist.h                         \
-       empathy-theme-adium.c                   \
-       empathy-theme-adium.h
-endif
-
 CLEANFILES =                           \
        $(BUILT_SOURCES)                \
        stamp-empathy-gtk-enum-types.h