]> git.0d.be Git - empathy.git/blobdiff - libempathy-gtk/Makefile.am
Merge branch 'log-window-webview'
[empathy.git] / libempathy-gtk / Makefile.am
index 065fa3f7bf57a62ed1b09ce7dce654aaf22a57ad..33dcbfb9332d954d27c72b2bb326fa4bc4d03778 100644 (file)
@@ -1,4 +1,3 @@
-include $(top_srcdir)/tools/shave.mk
 include $(top_srcdir)/tools/flymake.mk
 
 AM_CPPFLAGS =                                           \
@@ -7,12 +6,15 @@ AM_CPPFLAGS =                                           \
        -I$(top_srcdir)                                 \
        -DDATADIR=\""$(datadir)"\"                      \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
-       $(LIBEMPATHYGTK_CFLAGS)                         \
+       -DGCR_API_SUBJECT_TO_CHANGE                     \
+       $(EMPATHY_CFLAGS)                               \
+       $(YELL_CFLAGS)                                  \
        $(ENCHANT_CFLAGS)                               \
        $(LIBCHAMPLAIN_CFLAGS)                          \
        $(GEOCLUE_CFLAGS)                               \
-       $(MOBLIN_CFLAGS)                                \
-       $(WEBKIT_CFLAGS)                                \
+       $(GEOCODE_CFLAGS)                               \
+       $(MEEGO_CFLAGS)                                 \
+       $(CHEESE_CFLAGS)                                \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
@@ -27,87 +29,138 @@ noinst_LTLIBRARIES = libempathy-gtk.la
 
 libempathy_gtk_handwritten_source =                    \
        empathy-account-chooser.c               \
-       empathy-account-widget.c                \
-       empathy-account-widget-private.h        \
        empathy-account-widget-irc.c            \
+       empathy-account-widget-private.h        \
        empathy-account-widget-sip.c            \
+       empathy-account-widget.c                \
        empathy-avatar-chooser.c                \
        empathy-avatar-image.c                  \
+       empathy-call-utils.c                    \
        empathy-cell-renderer-activatable.c     \
        empathy-cell-renderer-expander.c        \
        empathy-cell-renderer-text.c            \
-       empathy-chat.c                          \
        empathy-chat-text-view.c                \
        empathy-chat-view.c                     \
-       empathy-conf.c                          \
+       empathy-chat.c                          \
+       empathy-contact-blocking-dialog.c       \
        empathy-contact-dialogs.c               \
+       empathy-contact-chooser.c               \
        empathy-contact-list-store.c            \
        empathy-contact-list-view.c             \
        empathy-contact-menu.c                  \
-       empathy-share-my-desktop.c              \
+       empathy-linking-dialog.c                \
+       empathy-live-search.c                   \
+       empathy-contact-search-dialog.c         \
        empathy-contact-selector.c              \
+       empathy-contact-selector-dialog.c \
        empathy-contact-widget.c                \
        empathy-geometry.c                      \
-       empathy-audio-sink.c                    \
-       empathy-audio-src.c                     \
-       empathy-video-src.c                     \
-       empathy-video-widget.c                  \
+       empathy-groups-widget.c                 \
+       empathy-individual-dialogs.c            \
+       empathy-individual-edit-dialog.c        \
+       empathy-individual-information-dialog.c \
+       empathy-individual-linker.c             \
+       empathy-individual-menu.c               \
+       empathy-individual-store.c              \
+       empathy-individual-view.c               \
+       empathy-individual-widget.c             \
+       empathy-input-text-view.c               \
+       empathy-irc-network-chooser.c \
+       empathy-irc-network-chooser-dialog.c \
        empathy-irc-network-dialog.c            \
        empathy-log-window.c                    \
        empathy-new-message-dialog.c            \
+       empathy-new-call-dialog.c               \
+       empathy-notify-manager.c                \
+       empathy-password-dialog.c               \
+       empathy-persona-store.c                 \
+       empathy-persona-view.c                  \
        empathy-presence-chooser.c              \
        empathy-protocol-chooser.c              \
+       empathy-search-bar.c                    \
+       empathy-share-my-desktop.c              \
        empathy-smiley-manager.c                \
-       empathy-sound.c                         \
+       empathy-sound-manager.c                 \
        empathy-spell.c                         \
        empathy-status-preset-dialog.c          \
+       empathy-string-parser.c                 \
        empathy-theme-boxes.c                   \
        empathy-theme-irc.c                     \
        empathy-theme-manager.c                 \
-       empathy-kludge-label.c                  \
-       empathy-ui-utils.c
+       empathy-tls-dialog.c                    \
+       empathy-ui-utils.c                      \
+       empathy-plist.c                         \
+       empathy-theme-adium.c                   \
+       empathy-webkit-utils.c                  \
+       $(NULL)
 
 libempathy_gtk_headers =                       \
        empathy-account-chooser.h               \
-       empathy-account-widget.h                \
        empathy-account-widget-irc.h            \
        empathy-account-widget-sip.h            \
+       empathy-account-widget.h                \
        empathy-avatar-chooser.h                \
        empathy-avatar-image.h                  \
+       empathy-call-utils.h                    \
        empathy-cell-renderer-activatable.h     \
        empathy-cell-renderer-expander.h        \
        empathy-cell-renderer-text.h            \
-       empathy-chat.h                          \
        empathy-chat-text-view.h                \
        empathy-chat-view.h                     \
-       empathy-conf.h                          \
+       empathy-chat.h                          \
+       empathy-contact-blocking-dialog.h       \
        empathy-contact-dialogs.h               \
+       empathy-contact-chooser.h               \
        empathy-contact-list-store.h            \
        empathy-contact-list-view.h             \
        empathy-contact-menu.h                  \
-       empathy-share-my-desktop.h              \
+       empathy-linking-dialog.h                \
+       empathy-live-search.h                   \
+       empathy-contact-search-dialog.h         \
        empathy-contact-selector.h              \
+       empathy-contact-selector-dialog.h \
        empathy-contact-widget.h                \
        empathy-geometry.h                      \
-       empathy-audio-sink.h                    \
-       empathy-audio-src.h                     \
-       empathy-video-src.h                     \
-       empathy-video-widget.h                  \
+       empathy-groups-widget.h                 \
        empathy-images.h                        \
+       empathy-individual-dialogs.h            \
+       empathy-individual-edit-dialog.h        \
+       empathy-individual-information-dialog.h \
+       empathy-individual-linker.h             \
+       empathy-individual-menu.h               \
+       empathy-individual-store.h              \
+       empathy-individual-view.h               \
+       empathy-individual-widget.h             \
+       empathy-input-text-view.h               \
+       empathy-irc-network-chooser.h \
+       empathy-irc-network-chooser-dialog.h \
        empathy-irc-network-dialog.h            \
        empathy-log-window.h                    \
        empathy-new-message-dialog.h            \
+       empathy-new-call-dialog.h               \
+       empathy-notify-manager.h                \
+       empathy-password-dialog.h               \
+       empathy-persona-store.h                 \
+       empathy-persona-view.h                  \
        empathy-presence-chooser.h              \
        empathy-protocol-chooser.h              \
+       empathy-search-bar.h                    \
+       empathy-share-my-desktop.h              \
        empathy-smiley-manager.h                \
-       empathy-sound.h                         \
+       empathy-sound-manager.h                 \
        empathy-spell.h                         \
        empathy-status-preset-dialog.h          \
+       empathy-string-parser.h                 \
        empathy-theme-boxes.h                   \
        empathy-theme-irc.h                     \
        empathy-theme-manager.h                 \
-       empathy-kludge-label.h                  \
-       empathy-ui-utils.h
+       empathy-tls-dialog.h                    \
+       empathy-ui-utils.h                      \
+       empathy-plist.h                         \
+       empathy-theme-adium.h                   \
+       empathy-webkit-utils.h                  \
+       $(NULL)
+
 
 libempathy_gtk_la_SOURCES =                    \
        $(libempathy_gtk_handwritten_source)    \
@@ -119,12 +172,18 @@ nodist_libempathy_gtk_la_SOURCES =\
        $(BUILT_SOURCES)
 
 libempathy_gtk_la_LIBADD =                     \
-       $(LIBEMPATHYGTK_LIBS)                   \
+       $(EMPATHY_LIBS)                 \
+       $(EMPATHY_LIBS)                 \
+       $(GTK_LIBS)                     \
+       $(LIBNOTIFY_LIBS)                       \
+       $(CANBERRA_LIBS) \
        $(ENCHANT_LIBS)                         \
        $(LIBCHAMPLAIN_LIBS)                    \
        $(GEOCLUE_LIBS)                         \
-       $(MOBLIN_LIBS)                          \
-       $(WEBKIT_LIBS)                          \
+       $(GEOCODE_LIBS)                         \
+       $(GCR_LIBS)                             \
+       $(MEEGO_LIBS)                           \
+       $(CHEESE_LIBS)                          \
        $(top_builddir)/libempathy/libempathy.la
 
 check_c_sources = \
@@ -137,6 +196,7 @@ uidir = $(datadir)/empathy
 ui_DATA =                                      \
        empathy-contact-widget.ui               \
        empathy-contact-dialogs.ui              \
+       empathy-contact-blocking-dialog.ui      \
        empathy-account-widget-generic.ui       \
        empathy-account-widget-jabber.ui        \
        empathy-account-widget-msn.ui           \
@@ -150,30 +210,32 @@ ui_DATA =                                         \
        empathy-status-preset-dialog.ui         \
        empathy-log-window.ui                   \
        empathy-chat.ui                         \
-       empathy-new-message-dialog.ui
+       empathy-contact-selector-dialog.ui      \
+       empathy-search-bar.ui                   \
+       empathy-individual-widget.ui
 
 empathy-gtk-marshal.list: $(libempathy_gtk_la_SOURCES) Makefile.am
-       $(QUIET_GEN)( cd $(srcdir) && \
+       $(AM_V_GEN)( cd $(srcdir) && \
        sed -n -e 's/.*empathy_gtk_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
        $(libempathy_gtk_la_SOURCES) ) \
        | sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
-       if cmp -s $@.tmp $@; then \
+       @if cmp -s $@.tmp $@; then \
                rm $@.tmp; \
        else \
                mv $@.tmp $@; \
        fi
 
 %-marshal.h: %-marshal.list Makefile
-       $(QUIET_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
+       $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
 
 %-marshal.c: %-marshal.list Makefile
-       $(QUIET_GEN)echo "#include \"empathy-gtk-marshal.h\"" > $@ && \
+       $(AM_V_GEN)echo "#include \"empathy-gtk-marshal.h\"" > $@ && \
        $(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
 
 empathy-gtk-enum-types.h: stamp-empathy-gtk-enum-types.h
-       $(QUIET_GEN)true
+       $(AM_V_GEN)true
 stamp-empathy-gtk-enum-types.h: Makefile $(libempathy_gtk_headers)
-       $(QUIET_GEN)(cd $(srcdir) \
+       $(AM_V_GEN)(cd $(srcdir) \
        && glib-mkenums \
                        --fhead "#ifndef __LIBEMPATHY_GTK_ENUM_TYPES_H__\n" \
                        --fhead "#define __LIBEMPATHY_GTK_ENUM_TYPES_H__ 1\n\n" \
@@ -190,7 +252,7 @@ stamp-empathy-gtk-enum-types.h: Makefile $(libempathy_gtk_headers)
        && echo timestamp > $(@F)
 
 empathy-gtk-enum-types.c: Makefile $(libempathy_gtk_headers)
-       $(QUIET_GEN)(cd $(srcdir) \
+       $(AM_V_GEN)(cd $(srcdir) \
        && glib-mkenums \
                        --fhead "#include <config.h>\n" \
                        --fhead "#include <glib-object.h>\n" \
@@ -223,21 +285,6 @@ EXTRA_DIST +=                                      \
        empathy-location-manager.h
 endif
 
-if HAVE_WEBKIT
-libempathy_gtk_handwritten_source +=           \
-       empathy-plist.c                         \
-       empathy-theme-adium.c
-libempathy_gtk_headers +=                      \
-       empathy-plist.h                         \
-       empathy-theme-adium.h
-else
-EXTRA_DIST +=                                  \
-       empathy-plist.c                         \
-       empathy-plist.h                         \
-       empathy-theme-adium.c                   \
-       empathy-theme-adium.h
-endif
-
 CLEANFILES =                           \
        $(BUILT_SOURCES)                \
        stamp-empathy-gtk-enum-types.h