]> git.0d.be Git - empathy.git/blobdiff - extensions/Makefile.am
sort contacts by most recent event
[empathy.git] / extensions / Makefile.am
index d0f10482195ae826ea36d37278dc492019e57fc3..79622d48a1231161035a39c6b9d0696b14b6efe6 100644 (file)
@@ -12,12 +12,8 @@ EXTRA_DIST = \
     all.xml \
     generic-types.xml \
     misc.xml \
-    Debug.xml \
     Logger.xml \
-    Connection_Interface_Renaming.xml \
-    Authentication_TLS_Certificate.xml \
     Channel_Interface_Credentials_Storage.xml \
-    Channel_Type_Server_TLS_Connection.xml \
     $(NULL)
 
 noinst_LTLIBRARIES = libemp-extensions.la
@@ -34,9 +30,6 @@ libemp_extensions_la_SOURCES = \
     extensions.h
 
 nodist_libemp_extensions_la_SOURCES = \
-    _gen/signals-marshal.c \
-    _gen/signals-marshal.h \
-    _gen/signals-marshal.list \
     _gen/register-dbus-glib-marshallers-body.h \
     _gen/enums.h \
     _gen/gtypes.h \
@@ -64,7 +57,7 @@ XSLTPROCFLAGS = --nonet --novalid
 # Generated files which can be generated for all categories simultaneously
 
 _gen/all.xml: all.xml $(wildcard *.xml) $(tools_dir)/xincludator.py
-       @$(mkdir_p) _gen
+       @$(MKDIR_P) _gen
        $(AM_V_GEN)$(PYTHON) $(tools_dir)/xincludator.py $< > $@
 
 extensions.html: _gen/all.xml $(tools_dir)/doc-generator.xsl
@@ -78,17 +71,6 @@ _gen/gtypes.h _gen/gtypes-body.h: _gen/all.xml \
        $(AM_V_GEN)$(PYTHON) $(top_srcdir)/tools/glib-gtypes-generator.py \
                $< _gen/gtypes Emp
 
-_gen/signals-marshal.list: _gen/all.xml \
-       $(tools_dir)/glib-signals-marshal-gen.py
-       $(AM_V_GEN)$(PYTHON) $(tools_dir)/glib-signals-marshal-gen.py $< > $@
-
-_gen/signals-marshal.h: _gen/signals-marshal.list Makefile.am
-       $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_emp_ext_marshal $< > $@
-
-_gen/signals-marshal.c: _gen/signals-marshal.list Makefile.am
-       $(AM_V_GEN){ echo '#include "_gen/signals-marshal.h"' && \
-       $(GLIB_GENMARSHAL) --body --prefix=_emp_ext_marshal $< ; } > $@
-
 _gen/register-dbus-glib-marshallers-body.h: _gen/all.xml \
        $(tools_dir)/glib-client-marshaller-gen.py
        $(AM_V_GEN)$(PYTHON) $(tools_dir)/glib-client-marshaller-gen.py $< \
@@ -110,10 +92,12 @@ _gen/interfaces-body.h _gen/interfaces.h: _gen/all.xml \
 # although you can subdivide further if you want.
 
 _gen/misc.xml: misc.xml $(wildcard *.xml) $(tools_dir)/xincludator.py
-       @$(mkdir_p) _gen
+       @$(MKDIR_P) _gen
        $(AM_V_GEN)$(PYTHON) $(tools_dir)/xincludator.py $< > $@
 
-_gen/cli-misc-body.h _gen/cli-misc.h: _gen/misc.xml \
+_gen/cli-misc-body.h: _gen/cli-misc.h
+
+_gen/cli-misc.h: _gen/misc.xml \
        $(tools_dir)/glib-client-gen.py
        $(AM_V_GEN)$(PYTHON) $(tools_dir)/glib-client-gen.py \
                --group=misc \
@@ -123,13 +107,22 @@ _gen/cli-misc-body.h _gen/cli-misc.h: _gen/misc.xml \
                --tp-proxy-api=0.10.0 \
                $< Emp_Cli _gen/cli-misc
 
-_gen/svc-misc.c _gen/svc-misc.h: _gen/misc.xml \
+# There is no need to execute glib-ginterface-gen.py twice because it
+# generates both the .c and .h files in one shot. Therefore, merely
+# having one of them (say the .c) depend on the other (say the .h) is
+# enough.
+#
+# Moreover, running it twice breaks parallel builds because one
+# glib-ginterface-gen.py process steps on the other.
+
+_gen/svc-misc.c: _gen/svc-misc.h
+
+_gen/svc-misc.h: _gen/misc.xml \
        $(tools_dir)/glib-ginterface-gen.py
        $(AM_V_GEN)$(PYTHON) $(tools_dir)/glib-ginterface-gen.py \
                --filename=_gen/svc-misc \
                --signal-marshal-prefix=_emp_ext \
-               --include='<telepathy-glib/dbus.h>' \
-               --include='"_gen/signals-marshal.h"' \
+               --include='<telepathy-glib/telepathy-glib.h>' \
                --not-implemented-func='tp_dbus_g_method_return_not_implemented' \
                --allow-unstable \
                $< Emp_Svc_