]> git.0d.be Git - empathy.git/blobdiff - extensions/Makefile.am
Make parallel builds work
[empathy.git] / extensions / Makefile.am
index bc4213309def14c1dcbec7918b69d75fe0c11de0..65f2f5e01aa0ee3aafdbd9c1cefac9c5a3670da4 100644 (file)
@@ -108,7 +108,17 @@ _gen/cli-misc-body.h _gen/cli-misc.h: _gen/misc.xml \
                --tp-proxy-api=0.10.0 \
                $< Emp_Cli _gen/cli-misc
 
-_gen/svc-misc.c _gen/svc-misc.h: _gen/misc.xml \
+# There is no need to execute glib-ginterface-gen.py twice because it
+# generates both the .c and .h files in one shot. Therefore, merely
+# having one of them (say the .c) depend on the other (say the .h) is
+# enough.
+#
+# Moreover, running it twice breaks parallel builds because one
+# glib-ginterface-gen.py process steps on the other.
+
+_gen/svc-misc.c: _gen/svc-misc.h
+
+_gen/svc-misc.h: _gen/misc.xml \
        $(tools_dir)/glib-ginterface-gen.py
        $(AM_V_GEN)$(PYTHON) $(tools_dir)/glib-ginterface-gen.py \
                --filename=_gen/svc-misc \