]> git.0d.be Git - empathy.git/blobdiff - data/Makefile.am
Run from the source directory without installing
[empathy.git] / data / Makefile.am
index 443cdeba4d8e090ae484f2ff0d94ca83277f1a68..a2be750cfe7f0cc76fecbfbf942de4c81885a9af 100644 (file)
@@ -15,6 +15,13 @@ gsettings_SCHEMAS = $(gsettings_files:.xml.in=.xml)
 @INTLTOOL_XML_NOMERGE_RULE@
 @GSETTINGS_RULES@
 
+# We need to compile schemas at make time
+# to run from source tree
+gschemas.compiled: $(gsettings_SCHEMAS:.xml=.valid)
+       $(AM_V_GEN) $(GLIB_COMPILE_SCHEMAS) --targetdir=. .
+
+all-local: gschemas.compiled
+
 convertdir = $(datarootdir)/GConf/gsettings
 convert_DATA = \
        empathy.convert
@@ -22,11 +29,15 @@ convert_DATA = \
 servicefiledir = $(datadir)/dbus-1/services
 servicefile_in_files = \
        org.freedesktop.Telepathy.Client.Empathy.Chat.service.in \
-       org.freedesktop.Telepathy.Client.Empathy.AudioVideo.service.in \
        org.freedesktop.Telepathy.Client.Empathy.Auth.service.in \
        org.freedesktop.Telepathy.Client.Empathy.Call.service.in \
        org.freedesktop.Telepathy.Client.Empathy.FileTransfer.service.in
 
+if HAVE_EMPATHY_AV
+servicefile_in_files += \
+       org.freedesktop.Telepathy.Client.Empathy.AudioVideo.service.in
+endif
+
 servicefile_DATA = $(servicefile_in_files:.service.in=.service)
 
 org.freedesktop.Telepathy.Client.Empathy.Chat.service: org.freedesktop.Telepathy.Client.Empathy.Chat.service.in
@@ -47,11 +58,15 @@ org.freedesktop.Telepathy.Client.Empathy.FileTransfer.service: org.freedesktop.T
 clientfiledir = $(datarootdir)/telepathy/clients
 clientfile_DATA = \
        Empathy.Chat.client \
-       Empathy.AudioVideo.client \
        Empathy.Auth.client \
        Empathy.Call.client \
        Empathy.FileTransfer.client
 
+if HAVE_EMPATHY_AV
+clientfile_DATA += \
+       Empathy.AudioVideo.client
+endif
+
 htmldir = $(datadir)/empathy
 html_DATA = \
        Template.html \
@@ -74,4 +89,5 @@ DISTCLEANFILES =              \
        $(schemas_DATA)         \
        $(servicefile_DATA)     \
        $(gsettings_SCHEMAS)    \
+       gschemas.compiled       \
        $(NULL)