]> git.0d.be Git - empathy.git/blobdiff - data/Makefile.am
Run from the source directory without installing
[empathy.git] / data / Makefile.am
index 24a7fb9d8013f14bd08571fc9d20d209cababb94..a2be750cfe7f0cc76fecbfbf942de4c81885a9af 100644 (file)
@@ -15,21 +15,28 @@ gsettings_SCHEMAS = $(gsettings_files:.xml.in=.xml)
 @INTLTOOL_XML_NOMERGE_RULE@
 @GSETTINGS_RULES@
 
+# We need to compile schemas at make time
+# to run from source tree
+gschemas.compiled: $(gsettings_SCHEMAS:.xml=.valid)
+       $(AM_V_GEN) $(GLIB_COMPILE_SCHEMAS) --targetdir=. .
+
+all-local: gschemas.compiled
+
 convertdir = $(datarootdir)/GConf/gsettings
 convert_DATA = \
        empathy.convert
 
-streamingprefsdir =  $(datadir)/empathy
-streamingprefs_DATA =          \
-       codec-preferences       \
-       element-properties
-
 servicefiledir = $(datadir)/dbus-1/services
 servicefile_in_files = \
        org.freedesktop.Telepathy.Client.Empathy.Chat.service.in \
-       org.freedesktop.Telepathy.Client.Empathy.AudioVideo.service.in \
        org.freedesktop.Telepathy.Client.Empathy.Auth.service.in \
-       org.freedesktop.Telepathy.Client.Empathy.Call.service.in
+       org.freedesktop.Telepathy.Client.Empathy.Call.service.in \
+       org.freedesktop.Telepathy.Client.Empathy.FileTransfer.service.in
+
+if HAVE_EMPATHY_AV
+servicefile_in_files += \
+       org.freedesktop.Telepathy.Client.Empathy.AudioVideo.service.in
+endif
 
 servicefile_DATA = $(servicefile_in_files:.service.in=.service)
 
@@ -45,22 +52,32 @@ org.freedesktop.Telepathy.Client.Empathy.Auth.service: org.freedesktop.Telepathy
 org.freedesktop.Telepathy.Client.Empathy.Call.service: org.freedesktop.Telepathy.Client.Empathy.Call.service.in
        $(AM_V_GEN)sed -e "s|[@]libexecdir[@]|$(libexecdir)|" $< > $@
 
+org.freedesktop.Telepathy.Client.Empathy.FileTransfer.service: org.freedesktop.Telepathy.Client.Empathy.FileTransfer.service.in
+       $(AM_V_GEN)sed -e "s|[@]bindir[@]|$(bindir)|" $< > $@
+
 clientfiledir = $(datarootdir)/telepathy/clients
 clientfile_DATA = \
        Empathy.Chat.client \
-       Empathy.AudioVideo.client \
        Empathy.Auth.client \
-       Empathy.Call.client
+       Empathy.Call.client \
+       Empathy.FileTransfer.client
+
+if HAVE_EMPATHY_AV
+clientfile_DATA += \
+       Empathy.AudioVideo.client
+endif
 
 htmldir = $(datadir)/empathy
-html_DATA = Template.html
+html_DATA = \
+       Template.html \
+       empathy-log-window.html \
+       $(NULL)
 
 EXTRA_DIST =                           \
        $(convert_DATA)                 \
        $(desktop_in_files)             \
        $(desktop_DATA)                 \
        $(schemas_DATA)                 \
-       $(streamingprefs_DATA)          \
        $(html_DATA)                    \
        $(clientfile_DATA)              \
        $(servicefile_in_files)         \
@@ -72,4 +89,5 @@ DISTCLEANFILES =              \
        $(schemas_DATA)         \
        $(servicefile_DATA)     \
        $(gsettings_SCHEMAS)    \
+       gschemas.compiled       \
        $(NULL)