Empathy should not require python-config. Fixes bug #525562 (Frederic Peters).
[empathy.git] / python / pyempathygtk / Makefile.am
1 PYDEFS=`pkg-config --variable=defsdir pygtk-2.0`
2
3 AM_CPPFLAGS =                                           \
4         -I.                                             \
5         -I$(top_srcdir)/libempathy-gtk                  \
6         -I$(top_srcdir)                                 \
7         -DDATADIR=\""$(datadir)"\"                      \
8         $(PYTHON_BINDING_CFLAGS)                        \
9         $(PYTHON_INCLUDES)
10
11 BUILT_SOURCES =                                         \
12         pyempathygtk.c                                  
13
14 pyempathygtkdir = $(pyexecdir)
15 pyempathygtk_LTLIBRARIES = empathygtk.la
16
17 empathygtk_la_SOURCES =                                 \
18         pyempathygtkmodule.c                            \
19         pyempathygtk.c
20
21 empathygtk_la_LIBADD =                                  \
22         $(PYTHON_BINDING_LIBS)                          \
23         $(top_builddir)/libempathy/libempathy.la        \
24         $(top_builddir)/libempathy-gtk/libempathy-gtk.la
25
26 empathygtk_la_LDFLAGS =                                 \
27         -module -avoid-version
28
29 pyempathygtk.c: pyempathygtk.override pyempathygtk.defs
30         pygtk-codegen-2.0                                               \
31                 --prefix empathy                                        \
32                 --register $(PYDEFS)/gdk-types.defs                     \
33                 --register $(PYDEFS)/gtk-types.defs                     \
34                 --register ../pyempathy/pyempathy.defs                  \
35                 --override pyempathygtk.override                        \
36                 pyempathygtk.defs > $@ 
37
38 EXTRA_DIST =                    \
39         pyempathygtk.override   \
40         pyempathygtk.defs
41
42 CLEANFILES = $(BUILT_SOURCES)
43