[darcs-to-svn @ initial import]
[empathy.git] / configure.ac
1 AC_INIT(Empathy, 0.1)
2 AC_PREREQ(2.59)
3 AC_COPYRIGHT([Copyright (C) 2003-2007 Imendio AB])
4
5 AM_CONFIG_HEADER(config.h)
6 AM_INIT_AUTOMAKE(1.9 dist-bzip2 no-define)
7
8 AM_MAINTAINER_MODE
9
10 AC_ISC_POSIX
11 AC_PROG_CC
12 AC_HEADER_STDC
13
14 AM_PROG_LIBTOOL
15 AM_PATH_GLIB_2_0
16 AC_PATH_XTRA
17
18 AC_PATH_PROG(DBUS_BINDING_TOOL, dbus-binding-tool)
19 AC_PATH_PROG(GCONFTOOL, gconftool-2)
20 AM_GCONF_SOURCE_2
21
22 IT_PROG_INTLTOOL([0.35.0])
23
24 GLIB_REQUIRED=2.12.0
25 GTK_REQUIRED=2.10.0
26 GCONF_REQUIRED=1.2.0
27 LIBGLADE_REQUIRED=2.0.0
28 TELEPATHY_REQUIRED=0.0.51
29 MISSION_CONTROL_REQUIRED=4.20
30
31 GLIB_GENMARSHAL=`$PKG_CONFIG glib-2.0 --variable=glib_genmarshal`
32 AC_SUBST(GLIB_GENMARSHAL)
33
34 IDT_COMPILE_WARNINGS
35
36 dnl -----------------------------------------------------------
37 dnl Pkg-Config dependency checks
38 dnl -----------------------------------------------------------
39
40 PKG_CHECK_MODULES(EMPATHY,
41 [
42    glib-2.0 >= $GLIB_REQUIRED
43    gobject-2.0
44    gtk+-2.0 >= $GTK_REQUIRED
45    gconf-2.0 >= $GCONF_REQUIRED
46    libglade-2.0 >= $LIBGLADE_REQUIRED
47    libgnomeui-2.0
48    libtelepathy >= $TELEPATHY_REQUIRED
49    libmissioncontrol >= $MISSION_CONTROL_REQUIRED
50 ])
51
52 dnl -----------------------------------------------------------
53 dnl Language Support
54 dnl -----------------------------------------------------------
55 GETTEXT_PACKAGE=empathy
56 AC_SUBST(GETTEXT_PACKAGE)
57 AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",[Gettext package name])
58
59 AM_GLIB_GNU_GETTEXT
60
61
62 dnl -----------------------------------------------------------
63 AC_OUTPUT([
64   Makefile
65   po/Makefile.in
66   profiles/Makefile
67   pixmaps/Makefile
68   libempathy/Makefile
69   libempathy-gtk/Makefile
70   launcher/Makefile
71   accounts/Makefile
72   contact-list/Makefile
73   chat/Makefile
74 ])
75