Updated Polish translation
[empathy.git] / autogen.sh
1 #!/bin/sh
2 # Run this to generate all the initial makefiles, etc.
3
4 srcdir=`dirname $0`
5 test -z "$srcdir" && srcdir=.
6
7 PKG_NAME="Empathy"
8 REQUIRED_AUTOMAKE_VERSION=1.9
9
10 (test -f $srcdir/configure.ac) || {
11     echo -n "**Error**: Directory "\`$srcdir\'" does not look like the"
12     echo " top-level gnome directory"
13     exit 1
14 }
15
16 # Fix to make shave + libtool 1.x + gtk-doc work.
17 # See http://git.lespiau.name/cgit/shave/tree/README#n83
18 sed -e 's#) --mode=compile#) --tag=CC --mode=compile#' gtk-doc.make \
19     > gtk-doc.temp \
20         && mv gtk-doc.temp gtk-doc.make
21 sed -e 's#) --mode=link#) --tag=CC --mode=link#' gtk-doc.make \
22                 > gtk-doc.temp \
23         && mv gtk-doc.temp gtk-doc.make
24
25 which gnome-autogen.sh || {
26     echo "You need to install gnome-common from the GNOME CVS"
27     exit 1
28 }
29 USE_GNOME2_MACROS=1 USE_COMMON_DOC_BUILD=yes . gnome-autogen.sh
30
31