Updated Polish translation
[empathy.git] / Makefile.am
1 SUBDIRS = tools extensions po data libempathy libempathy-gtk src docs help
2
3 if HAVE_MEGAPHONE
4 SUBDIRS += megaphone
5 endif
6
7 if HAVE_NOTHERE
8 SUBDIRS += nothere
9 endif
10
11 if HAVE_PYTHON
12 SUBDIRS += python
13 endif
14
15 if HAVE_TESTS
16 SUBDIRS += tests
17 endif
18
19 ACLOCAL_AMFLAGS = -I m4
20
21 DISTCHECK_CONFIGURE_FLAGS =             \
22         --disable-scrollkeeper          \
23         --disable-schemas-install       \
24         --enable-gtk-doc
25
26 EXTRA_DIST =                    \
27         ChangeLog               \
28         ChangeLog.old           \
29         README                  \
30         CONTRIBUTORS            \
31         autogen.sh
32
33 DISTCLEANFILES =                \
34         ChangeLog
35
36 # Workaround broken scrollkeeper that doesn't remove its files on
37 # uninstall.
38 distuninstallcheck_listfiles = find . -type f -print | grep -v '^\./var/scrollkeeper'
39
40 distclean-local:
41         if test "x$(srdcir)" = "x."; then :; else \
42                 rm -f ChangeLog; \
43         fi
44
45 ChangeLog:
46         @echo Creating $@
47         @if test -d "$(srcdir)/.git"; then \
48           (GIT_DIR=$(top_srcdir)/.git ./missing --run git log EMPATHY_2_27_1.. --stat) | fmt --split-only > $@.tmp \
49           && mv -f $@.tmp $@ \
50           || ($(RM) $@.tmp; \
51               echo Failed to generate ChangeLog, your ChangeLog may be outdated >&2; \
52               (test -f $@ || echo git-log is required to generate this file >> $@)); \
53         else \
54           test -f $@ || \
55           (echo A git checkout and git-log is required to generate ChangeLog >&2 && \
56           echo A git checkout and git-log is required to generate this file >> $@); \
57         fi
58
59 .PHONY: ChangeLog
60