Merge branch 'sasl'
[empathy.git] / Makefile.am
1 MY_SUBDIRS = tools extensions po data libempathy libempathy-gtk src help tests
2 NST_SUBDIRS = nautilus-sendto-plugin
3
4 DIST_SUBDIRS = $(MY_SUBDIRS) $(NST_SUBDIRS)
5
6 SUBDIRS = $(MY_SUBDIRS)
7
8 if HAVE_NST
9 SUBDIRS += $(NST_SUBDIRS)
10 endif
11
12 ACLOCAL_AMFLAGS = -I m4
13
14 DISTCHECK_CONFIGURE_FLAGS =             \
15         --disable-scrollkeeper          \
16         --disable-schemas-install
17
18 EXTRA_DIST =                    \
19         CONTRIBUTORS \
20         COPYING-DOCS \
21         COPYING.LGPL \
22         COPYING.SHARE-ALIKE \
23         ChangeLog \
24         ChangeLog.old \
25         README \
26         autogen.sh \
27         $(NULL)
28
29 DISTCLEANFILES =                \
30         ChangeLog
31
32 # Workaround broken scrollkeeper that doesn't remove its files on
33 # uninstall.
34 distuninstallcheck_listfiles = find . -type f -print | grep -v '^\./var/scrollkeeper'
35
36 distclean-local:
37         if test "x$(srcdir)" = "x."; then :; else \
38                 rm -f ChangeLog; \
39         fi
40
41 ChangeLog:
42         @echo Creating $@
43         @if test -d "$(srcdir)/.git"; then \
44           (GIT_DIR=$(top_srcdir)/.git ./missing --run git log EMPATHY_2_27_1.. --stat) | fmt --split-only > $@.tmp \
45           && mv -f $@.tmp $@ \
46           || ($(RM) $@.tmp; \
47               echo Failed to generate ChangeLog, your ChangeLog may be outdated >&2; \
48               (test -f $@ || echo git-log is required to generate this file >> $@)); \
49         else \
50           test -f $@ || \
51           (echo A git checkout and git-log is required to generate ChangeLog >&2 && \
52           echo A git checkout and git-log is required to generate this file >> $@); \
53         fi
54
55 .PHONY: ChangeLog
56